summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/ar7/Makefile2
-rw-r--r--target/linux/ar71xx/Makefile2
-rw-r--r--target/linux/atheros/Makefile2
-rw-r--r--target/linux/au1000/Makefile2
-rw-r--r--target/linux/avr32/Makefile2
-rw-r--r--target/linux/brcm47xx/patches-2.6.37/022-USB-Add-ehci-ssb-driver.patch6
-rw-r--r--target/linux/brcm47xx/patches-2.6.37/023-usb_ehci_ohci.patch4
-rw-r--r--target/linux/brcm47xx/patches-2.6.37/700-ssb-gigabit-ethernet-driver.patch16
-rw-r--r--target/linux/brcm47xx/patches-2.6.37/830-tg3_add_pci_ids.patch4
-rw-r--r--target/linux/brcm47xx/patches-2.6.37/977-ssb_export_fallback_sprom.patch2
-rw-r--r--target/linux/gemini/Makefile2
-rw-r--r--target/linux/generic/patches-2.6.37/010-debloat_lzma.patch6
-rw-r--r--target/linux/generic/patches-2.6.37/281-solos_uniform_vpi_vci.patch6
-rw-r--r--target/linux/generic/patches-2.6.37/980-vm_exports.patch2
-rw-r--r--target/linux/ixp4xx/Makefile2
-rw-r--r--target/linux/lantiq/Makefile2
-rw-r--r--target/linux/malta/Makefile2
-rw-r--r--target/linux/orion/Makefile2
-rw-r--r--target/linux/realview/Makefile2
-rw-r--r--target/linux/uml/Makefile2
-rw-r--r--target/linux/xburst/Makefile2
22 files changed, 37 insertions, 39 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index ae06f0b525..7d343a6688 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -20,8 +20,8 @@ endif
ifeq ($(LINUX_VERSION),2.6.36.4)
LINUX_KERNEL_MD5SUM:=c05dd941d0e249695e9f72568888e1bf
endif
-ifeq ($(LINUX_VERSION),2.6.37.1)
- LINUX_KERNEL_MD5SUM:=07d3b1868a67c1a7ddcf1d54444cb5d1
+ifeq ($(LINUX_VERSION),2.6.37.3)
+ LINUX_KERNEL_MD5SUM:=b32fc95037e4e114fcfb33075bb30f46
endif
# disable the md5sum check for unknown kernel versions
diff --git a/target/linux/ar7/Makefile b/target/linux/ar7/Makefile
index 858996fed6..e2cbc12eeb 100644
--- a/target/linux/ar7/Makefile
+++ b/target/linux/ar7/Makefile
@@ -11,7 +11,7 @@ BOARD:=ar7
BOARDNAME:=TI AR7
FEATURES:=squashfs jffs2 atm
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ar71xx/Makefile b/target/linux/ar71xx/Makefile
index b0b096a2fe..4414177deb 100644
--- a/target/linux/ar71xx/Makefile
+++ b/target/linux/ar71xx/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
SUBTARGETS:=generic nand
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/atheros/Makefile b/target/linux/atheros/Makefile
index dabd71988c..e9e8ec3814 100644
--- a/target/linux/atheros/Makefile
+++ b/target/linux/atheros/Makefile
@@ -11,7 +11,7 @@ BOARD:=atheros
BOARDNAME:=Atheros AR231x/AR5312
FEATURES:=squashfs jffs2
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/au1000/Makefile b/target/linux/au1000/Makefile
index 23379b9d79..5fdea90ee2 100644
--- a/target/linux/au1000/Makefile
+++ b/target/linux/au1000/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=RMI/AMD AU1x00
FEATURES:=jffs2 usb pci
SUBTARGETS=au1500 au1550
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += wpad-mini yamonenv
diff --git a/target/linux/avr32/Makefile b/target/linux/avr32/Makefile
index d0570a68f8..4d544bd782 100644
--- a/target/linux/avr32/Makefile
+++ b/target/linux/avr32/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
FEATURES:=squashfs
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/brcm47xx/patches-2.6.37/022-USB-Add-ehci-ssb-driver.patch b/target/linux/brcm47xx/patches-2.6.37/022-USB-Add-ehci-ssb-driver.patch
index 6d15783b1c..0f9a800949 100644
--- a/target/linux/brcm47xx/patches-2.6.37/022-USB-Add-ehci-ssb-driver.patch
+++ b/target/linux/brcm47xx/patches-2.6.37/022-USB-Add-ehci-ssb-driver.patch
@@ -37,7 +37,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
depends on USB
--- a/drivers/usb/host/ehci-hcd.c
+++ b/drivers/usb/host/ehci-hcd.c
-@@ -1216,9 +1216,14 @@ MODULE_LICENSE ("GPL");
+@@ -1229,9 +1229,14 @@ MODULE_LICENSE ("GPL");
#define PLATFORM_DRIVER ehci_octeon_driver
#endif
@@ -53,7 +53,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
#error "missing bus glue for ehci-hcd"
#endif
-@@ -1278,10 +1283,20 @@ static int __init ehci_hcd_init(void)
+@@ -1291,10 +1296,20 @@ static int __init ehci_hcd_init(void)
if (retval < 0)
goto clean4;
#endif
@@ -75,7 +75,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
clean4:
#endif
#ifdef OF_PLATFORM_DRIVER
-@@ -1312,6 +1327,9 @@ module_init(ehci_hcd_init);
+@@ -1325,6 +1340,9 @@ module_init(ehci_hcd_init);
static void __exit ehci_hcd_cleanup(void)
{
diff --git a/target/linux/brcm47xx/patches-2.6.37/023-usb_ehci_ohci.patch b/target/linux/brcm47xx/patches-2.6.37/023-usb_ehci_ohci.patch
index 0d264d70c5..2f6bbfe1d2 100644
--- a/target/linux/brcm47xx/patches-2.6.37/023-usb_ehci_ohci.patch
+++ b/target/linux/brcm47xx/patches-2.6.37/023-usb_ehci_ohci.patch
@@ -152,7 +152,7 @@
+#endif
--- a/drivers/usb/host/ehci-hcd.c
+++ b/drivers/usb/host/ehci-hcd.c
-@@ -1284,17 +1284,21 @@ static int __init ehci_hcd_init(void)
+@@ -1297,17 +1297,21 @@ static int __init ehci_hcd_init(void)
goto clean4;
#endif
@@ -174,7 +174,7 @@
#ifdef XILINX_OF_PLATFORM_DRIVER
of_unregister_platform_driver(&XILINX_OF_PLATFORM_DRIVER);
clean4:
-@@ -1327,9 +1331,11 @@ module_init(ehci_hcd_init);
+@@ -1340,9 +1344,11 @@ module_init(ehci_hcd_init);
static void __exit ehci_hcd_cleanup(void)
{
diff --git a/target/linux/brcm47xx/patches-2.6.37/700-ssb-gigabit-ethernet-driver.patch b/target/linux/brcm47xx/patches-2.6.37/700-ssb-gigabit-ethernet-driver.patch
index 2915e3e9b8..7d9c8f8e30 100644
--- a/target/linux/brcm47xx/patches-2.6.37/700-ssb-gigabit-ethernet-driver.patch
+++ b/target/linux/brcm47xx/patches-2.6.37/700-ssb-gigabit-ethernet-driver.patch
@@ -211,7 +211,7 @@
if (tg3_nvram_read(tp, 0, &magic) != 0)
return -EIO;
-@@ -11169,7 +11230,7 @@ static int tg3_ioctl(struct net_device *
+@@ -11171,7 +11232,7 @@ static int tg3_ioctl(struct net_device *
return -EAGAIN;
spin_lock_bh(&tp->lock);
@@ -220,7 +220,7 @@
spin_unlock_bh(&tp->lock);
data->val_out = mii_regval;
-@@ -11185,7 +11246,7 @@ static int tg3_ioctl(struct net_device *
+@@ -11189,7 +11250,7 @@ static int tg3_ioctl(struct net_device *
return -EAGAIN;
spin_lock_bh(&tp->lock);
@@ -229,7 +229,7 @@
spin_unlock_bh(&tp->lock);
return err;
-@@ -11830,6 +11891,12 @@ static void __devinit tg3_get_5717_nvram
+@@ -11834,6 +11895,12 @@ static void __devinit tg3_get_5717_nvram
/* Chips other than 5700/5701 use the NVRAM for fetching info. */
static void __devinit tg3_nvram_init(struct tg3 *tp)
{
@@ -242,7 +242,7 @@
tw32_f(GRC_EEPROM_ADDR,
(EEPROM_ADDR_FSM_RESET |
(EEPROM_DEFAULT_CLOCK_PERIOD <<
-@@ -12093,6 +12160,9 @@ static int tg3_nvram_write_block(struct
+@@ -12097,6 +12164,9 @@ static int tg3_nvram_write_block(struct
{
int ret;
@@ -252,7 +252,7 @@
if (tp->tg3_flags & TG3_FLAG_EEPROM_WRITE_PROT) {
tw32_f(GRC_LOCAL_CTRL, tp->grc_local_ctrl &
~GRC_LCLCTRL_GPIO_OUTPUT1);
-@@ -13518,6 +13588,11 @@ static int __devinit tg3_get_invariants(
+@@ -13522,6 +13592,11 @@ static int __devinit tg3_get_invariants(
GET_ASIC_REV(tp->pci_chip_rev_id) == ASIC_REV_5701)))
tp->tg3_flags |= TG3_FLAG_SRAM_USE_CONFIG;
@@ -264,7 +264,7 @@
/* Get eeprom hw config before calling tg3_set_power_state().
* In particular, the TG3_FLG2_IS_NIC flag must be
* determined before calling tg3_set_power_state() so that
-@@ -13916,6 +13991,10 @@ static int __devinit tg3_get_device_addr
+@@ -13920,6 +13995,10 @@ static int __devinit tg3_get_device_addr
}
if (!is_valid_ether_addr(&dev->dev_addr[0])) {
@@ -275,7 +275,7 @@
#ifdef CONFIG_SPARC
if (!tg3_get_default_macaddr_sparc(tp))
return 0;
-@@ -14432,6 +14511,7 @@ static char * __devinit tg3_phy_string(s
+@@ -14436,6 +14515,7 @@ static char * __devinit tg3_phy_string(s
case TG3_PHY_ID_BCM5704: return "5704";
case TG3_PHY_ID_BCM5705: return "5705";
case TG3_PHY_ID_BCM5750: return "5750";
@@ -283,7 +283,7 @@
case TG3_PHY_ID_BCM5752: return "5752";
case TG3_PHY_ID_BCM5714: return "5714";
case TG3_PHY_ID_BCM5780: return "5780";
-@@ -14643,6 +14723,13 @@ static int __devinit tg3_init_one(struct
+@@ -14647,6 +14727,13 @@ static int __devinit tg3_init_one(struct
tp->msg_enable = tg3_debug;
else
tp->msg_enable = TG3_DEF_MSG_ENABLE;
diff --git a/target/linux/brcm47xx/patches-2.6.37/830-tg3_add_pci_ids.patch b/target/linux/brcm47xx/patches-2.6.37/830-tg3_add_pci_ids.patch
index 7166794a89..6bb25b9b1f 100644
--- a/target/linux/brcm47xx/patches-2.6.37/830-tg3_add_pci_ids.patch
+++ b/target/linux/brcm47xx/patches-2.6.37/830-tg3_add_pci_ids.patch
@@ -23,7 +23,7 @@ Date: Thu Dec 16 20:01:17 2010 +0100
{PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, PCI_DEVICE_ID_TIGON3_5752)},
--- a/include/linux/pci_ids.h
+++ b/include/linux/pci_ids.h
-@@ -2067,6 +2067,7 @@
+@@ -2068,6 +2068,7 @@
#define PCI_DEVICE_ID_NX2_57711E 0x1650
#define PCI_DEVICE_ID_TIGON3_5705 0x1653
#define PCI_DEVICE_ID_TIGON3_5705_2 0x1654
@@ -31,7 +31,7 @@ Date: Thu Dec 16 20:01:17 2010 +0100
#define PCI_DEVICE_ID_TIGON3_5721 0x1659
#define PCI_DEVICE_ID_TIGON3_5722 0x165a
#define PCI_DEVICE_ID_TIGON3_5723 0x165b
-@@ -2080,11 +2081,13 @@
+@@ -2081,11 +2082,13 @@
#define PCI_DEVICE_ID_TIGON3_5754M 0x1672
#define PCI_DEVICE_ID_TIGON3_5755M 0x1673
#define PCI_DEVICE_ID_TIGON3_5756 0x1674
diff --git a/target/linux/brcm47xx/patches-2.6.37/977-ssb_export_fallback_sprom.patch b/target/linux/brcm47xx/patches-2.6.37/977-ssb_export_fallback_sprom.patch
index 2a22a3a38f..b13563d69d 100644
--- a/target/linux/brcm47xx/patches-2.6.37/977-ssb_export_fallback_sprom.patch
+++ b/target/linux/brcm47xx/patches-2.6.37/977-ssb_export_fallback_sprom.patch
@@ -10,7 +10,7 @@
bool ssb_is_sprom_available(struct ssb_bus *bus)
--- a/include/linux/ssb/ssb.h
+++ b/include/linux/ssb/ssb.h
-@@ -401,6 +401,7 @@ extern bool ssb_is_sprom_available(struc
+@@ -408,6 +408,7 @@ extern bool ssb_is_sprom_available(struc
/* Set a fallback SPROM.
* See kdoc at the function definition for complete documentation. */
extern int ssb_arch_set_fallback_sprom(const struct ssb_sprom *sprom);
diff --git a/target/linux/gemini/Makefile b/target/linux/gemini/Makefile
index ef0cf4b360..f939c0edd1 100644
--- a/target/linux/gemini/Makefile
+++ b/target/linux/gemini/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs
CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -funit-at-a-time
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/generic/patches-2.6.37/010-debloat_lzma.patch b/target/linux/generic/patches-2.6.37/010-debloat_lzma.patch
index 18e4a51ee3..1e41661ebb 100644
--- a/target/linux/generic/patches-2.6.37/010-debloat_lzma.patch
+++ b/target/linux/generic/patches-2.6.37/010-debloat_lzma.patch
@@ -124,7 +124,7 @@
/* LzmaDecode
--- a/lib/lzma/LzmaDec.c
+++ b/lib/lzma/LzmaDec.c
-@@ -682,7 +682,7 @@ static void LzmaDec_InitRc(CLzmaDec *p,
+@@ -682,7 +682,7 @@ static void LzmaDec_InitRc(CLzmaDec *p,
p->needFlush = 0;
}
@@ -194,7 +194,7 @@
{
CLzmaProps propNew;
RINOK(LzmaProps_Decode(&propNew, props, propsSize));
-@@ -944,7 +944,7 @@ SRes LzmaDec_AllocateProbs(CLzmaDec *p,
+@@ -944,7 +944,7 @@ SRes LzmaDec_AllocateProbs(CLzmaDec *p,
return SZ_OK;
}
@@ -375,7 +375,7 @@
void MatchFinder_Construct(CMatchFinder *p);
/* Conditions:
-@@ -70,12 +65,6 @@ int MatchFinder_Create(CMatchFinder *p,
+@@ -70,12 +65,6 @@ int MatchFinder_Create(CMatchFinder *p,
UInt32 keepAddBufferBefore, UInt32 matchMaxLen, UInt32 keepAddBufferAfter,
ISzAlloc *alloc);
void MatchFinder_Free(CMatchFinder *p, ISzAlloc *alloc);
diff --git a/target/linux/generic/patches-2.6.37/281-solos_uniform_vpi_vci.patch b/target/linux/generic/patches-2.6.37/281-solos_uniform_vpi_vci.patch
index 06d3f8c08c..a3a49bb31a 100644
--- a/target/linux/generic/patches-2.6.37/281-solos_uniform_vpi_vci.patch
+++ b/target/linux/generic/patches-2.6.37/281-solos_uniform_vpi_vci.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.37/drivers/atm/solos-pci.c
-===================================================================
---- linux-2.6.37.orig/drivers/atm/solos-pci.c 2011-03-05 21:46:26.136023697 +0100
-+++ linux-2.6.37/drivers/atm/solos-pci.c 2011-03-05 21:48:49.046598163 +0100
+--- a/drivers/atm/solos-pci.c
++++ b/drivers/atm/solos-pci.c
@@ -710,8 +710,8 @@ void solos_bh(unsigned long card_arg)
le16_to_cpu(header->vci));
if (!vcc) {
diff --git a/target/linux/generic/patches-2.6.37/980-vm_exports.patch b/target/linux/generic/patches-2.6.37/980-vm_exports.patch
index 8d8638be31..2a965b22fd 100644
--- a/target/linux/generic/patches-2.6.37/980-vm_exports.patch
+++ b/target/linux/generic/patches-2.6.37/980-vm_exports.patch
@@ -94,7 +94,7 @@
/**
* zap_vma_ptes - remove ptes mapping the vma
-@@ -2614,6 +2615,7 @@ int vmtruncate_range(struct inode *inode
+@@ -2616,6 +2617,7 @@ int vmtruncate_range(struct inode *inode
return 0;
}
diff --git a/target/linux/ixp4xx/Makefile b/target/linux/ixp4xx/Makefile
index ac2e7ef538..7429c2be38 100644
--- a/target/linux/ixp4xx/Makefile
+++ b/target/linux/ixp4xx/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
SUBTARGETS=generic harddisk
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/lantiq/Makefile b/target/linux/lantiq/Makefile
index f9a4e0f9a4..14c24813c6 100644
--- a/target/linux/lantiq/Makefile
+++ b/target/linux/lantiq/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Lantiq GPON/XWAY
FEATURES:=squashfs jffs2
SUBTARGETS:=falcon xway
-LINUX_VERSION:=2.6.37.2
+LINUX_VERSION:=2.6.37.3
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
diff --git a/target/linux/malta/Makefile b/target/linux/malta/Makefile
index 32e193ecce..e690518d73 100644
--- a/target/linux/malta/Makefile
+++ b/target/linux/malta/Makefile
@@ -12,7 +12,7 @@ CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
SUBTARGETS:=le be
INITRAMFS_EXTRA_FILES:=
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/orion/Makefile b/target/linux/orion/Makefile
index a2dd84bb00..aeb47a4f11 100644
--- a/target/linux/orion/Makefile
+++ b/target/linux/orion/Makefile
@@ -13,7 +13,7 @@ SUBTARGETS:=generic harddisk
CFLAGS=-Os -pipe -march=armv5t -mtune=xscale -funit-at-a-time
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/realview/Makefile b/target/linux/realview/Makefile
index 00b7a331a9..add1a11696 100644
--- a/target/linux/realview/Makefile
+++ b/target/linux/realview/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=ARM Ltd. Realview board (qemu)
FEATURES:=squashfs jffs2 fpu
CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -funit-at-a-time
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/uml/Makefile b/target/linux/uml/Makefile
index 2c039f4f23..f5abf461fc 100644
--- a/target/linux/uml/Makefile
+++ b/target/linux/uml/Makefile
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
FEATURES:=ext4 audio
LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/xburst/Makefile b/target/linux/xburst/Makefile
index c58242a1be..21fe6452db 100644
--- a/target/linux/xburst/Makefile
+++ b/target/linux/xburst/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
FEATURES:=jffs2 targz ubifs audio
SUBTARGETS:=qi_lb60 n516 n526 id800wt
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
DEVICE_TYPE=other
258'>1258 1259 1260 1261 1262 1263 1264 1265 1266 1267 1268 1269 1270 1271 1272 1273 1274 1275 1276 1277 1278 1279 1280 1281 1282 1283 1284 1285 1286 1287 1288 1289 1290 1291 1292 1293 1294 1295 1296 1297 1298 1299 1300 1301 1302 1303 1304 1305 1306 1307 1308 1309 1310 1311 1312 1313 1314 1315 1316 1317 1318 1319 1320 1321 1322 1323 1324 1325 1326 1327 1328 1329 1330 1331 1332 1333 1334 1335 1336 1337 1338 1339 1340 1341 1342 1343 1344 1345 1346 1347 1348 1349 1350 1351 1352 1353 1354 1355 1356 1357 1358 1359 1360 1361 1362 1363 1364 1365 1366 1367 1368 1369 1370 1371 1372 1373 1374 1375 1376 1377 1378 1379 1380 1381 1382 1383 1384 1385 1386 1387 1388 1389 1390 1391 1392 1393 1394 1395 1396 1397 1398 1399 1400 1401 1402 1403 1404 1405 1406 1407 1408 1409 1410 1411 1412 1413 1414 1415 1416 1417 1418 1419 1420 1421 1422 1423 1424 1425 1426 1427 1428 1429 1430 1431 1432 1433 1434 1435 1436 1437 1438 1439 1440 1441 1442 1443 1444 1445 1446 1447 1448 1449 1450 1451 1452 1453 1454 1455 1456 1457 1458 1459 1460 1461 1462 1463 1464 1465 1466 1467 1468 1469 1470 1471 1472 1473 1474 1475 1476 1477 1478 1479 1480 1481 1482 1483 1484 1485 1486 1487 1488 1489 1490 1491 1492 1493 1494 1495 1496 1497 1498 1499 1500 1501 1502 1503 1504 1505 1506 1507 1508 1509 1510 1511 1512 1513 1514 1515 1516 1517 1518 1519 1520 1521 1522 1523 1524 1525 1526 1527 1528 1529 1530 1531 1532 1533 1534 1535 1536 1537 1538 1539 1540 1541 1542 1543 1544 1545 1546 1547 1548 1549 1550 1551 1552 1553 1554 1555 1556 1557 1558 1559 1560 1561 1562 1563 1564 1565 1566 1567 1568 1569 1570 1571 1572 1573 1574 1575 1576 1577 1578 1579 1580 1581 1582 1583 1584 1585 1586 1587 1588 1589 1590 1591 1592 1593 1594 1595 1596 1597 1598 1599 1600 1601 1602 1603 1604 1605 1606 1607 1608 1609 1610 1611 1612 1613 1614 1615 1616 1617 1618 1619 1620 1621 1622 1623 1624 1625 1626 1627 1628 1629 1630 1631 1632 1633 1634 1635 1636 1637 1638 1639 1640 1641 1642 1643 1644 1645 1646 1647 1648 1649 1650 1651 1652 1653 1654 1655 1656 1657 1658 1659 1660 1661 1662 1663 1664 1665 1666 1667 1668 1669 1670 1671 1672 1673 1674 1675 1676 1677 1678 1679 1680 1681 1682 1683 1684 1685 1686 1687 1688 1689 1690 1691 1692 1693 1694 1695 1696 1697 1698 1699 1700 1701 1702 1703 1704 1705 1706 1707 1708 1709 1710 1711 1712 1713 1714 1715 1716 1717 1718 1719 1720 1721 1722 1723 1724 1725 1726 1727 1728 1729 1730 1731 1732 1733 1734 1735 1736 1737 1738 1739 1740 1741 1742 1743 1744 1745 1746 1747 1748 1749 1750 1751 1752 1753 1754 1755 1756 1757 1758 1759 1760 1761 1762 1763 1764 1765 1766 1767 1768 1769