summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/modules/other.mk19
-rw-r--r--target/linux/generic/files/drivers/pwm/Makefile2
2 files changed, 18 insertions, 3 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 3781cbe329..b61b529c75 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -679,11 +679,26 @@ endef
$(eval $(call KernelPackage,wdt-scx200))
+define KernelPackage/pwm
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=PWM generic API
+ KCONFIG:=CONFIG_GENERIC_PWM
+ FILES:=$(LINUX_DIR)/drivers/pwm/pwm.ko
+ AUTOLOAD:=$(call AutoLoad,50,pwm)
+endef
+
+define KernelPackage/pwm/description
+ Kernel module that implement a generic PWM API
+endef
+
+$(eval $(call KernelPackage,pwm))
+
+
define KernelPackage/pwm-gpio
SUBMENU:=$(OTHER_MENU)
TITLE:=PWM over GPIO
- KCONFIG:=CONFIG_GENERIC_PWM \
- CONFIG_GPIO_PWM
+ DEPENDS:=+kmod-pwm
+ KCONFIG:=CONFIG_GPIO_PWM
FILES:=$(LINUX_DIR)/drivers/pwm/gpio-pwm.ko
AUTOLOAD:=$(call AutoLoad,51,gpio-pwm)
endef
diff --git a/target/linux/generic/files/drivers/pwm/Makefile b/target/linux/generic/files/drivers/pwm/Makefile
index 1c0e98e357..af22041bf2 100644
--- a/target/linux/generic/files/drivers/pwm/Makefile
+++ b/target/linux/generic/files/drivers/pwm/Makefile
@@ -1,6 +1,6 @@
#
# Makefile for pwm devices
#
-obj-y := pwm.o
+obj-$(CONFIG_GENERIC_PWM) := pwm.o
obj-$(CONFIG_ATMEL_PWM) += atmel-pwm.o
obj-$(CONFIG_GPIO_PWM) += gpio-pwm.o