summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/scons.mk2
-rw-r--r--tools/scons/patches/001-platform_env.patch11
2 files changed, 13 insertions, 0 deletions
diff --git a/include/scons.mk b/include/scons.mk
index 223aedefaf..5062681d63 100644
--- a/include/scons.mk
+++ b/include/scons.mk
@@ -1,3 +1,5 @@
+export PLATFORM=posix
+
SCONS_VARS = \
CC="$(TARGET_CC)" \
CXX="$(TARGET_CXX)" \
diff --git a/tools/scons/patches/001-platform_env.patch b/tools/scons/patches/001-platform_env.patch
new file mode 100644
index 0000000000..8aab9041c7
--- /dev/null
+++ b/tools/scons/patches/001-platform_env.patch
@@ -0,0 +1,11 @@
+--- a/engine/SCons/Platform/__init__.py
++++ b/engine/SCons/Platform/__init__.py
+@@ -63,6 +63,8 @@ def platform_default():
+ care about the machine architecture.
+ """
+ osname = os.name
++ if 'PLATFORM' in os.environ:
++ return os.environ['PLATFORM']
+ if osname == 'java':
+ osname = os._osType
+ if osname == 'posix':