summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/image/x86/Config.in13
-rw-r--r--target/image/x86/Makefile2
2 files changed, 14 insertions, 1 deletions
diff --git a/target/image/x86/Config.in b/target/image/x86/Config.in
index 88d8d37c3b..2c3e8840cc 100644
--- a/target/image/x86/Config.in
+++ b/target/image/x86/Config.in
@@ -14,4 +14,17 @@ config X86_GRUB_KERNELPART
depends X86_GRUB_IMAGES
default 4
+config X86_GRUB_ROOTPART
+ string
+ prompt "Root partition on target device" if X86_GRUB_IMAGES
+ default "/dev/hda2"
+ help
+ The root partition on the final device. If you don't know,
+ you probably want the default (/dev/hda2).
+config X86_GRUB_BOOTOPTS
+ string
+ prompt "Extra kernel boot options" if X86_GRUB_IMAGES
+ default ""
+ help
+ If you don't know leave it blank
diff --git a/target/image/x86/Makefile b/target/image/x86/Makefile
index 0860245453..8c0cde440f 100644
--- a/target/image/x86/Makefile
+++ b/target/image/x86/Makefile
@@ -25,7 +25,7 @@ ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
endef
define Image/cmdline/ext2
- root=/dev/hda2 rootfstype=ext2
+ root=$(CONFIG_X86_GRUB_ROOTPART) rootfstype=ext2 $(CONFIG_X86_GRUB_BOOTOPTS)
endef
define Image/Build/grub