summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/network/ipv6/map/Makefile2
-rw-r--r--package/network/ipv6/map/src/mapcalc.c3
2 files changed, 4 insertions, 1 deletions
diff --git a/package/network/ipv6/map/Makefile b/package/network/ipv6/map/Makefile
index 2a029f8fe8..09ba523ec0 100644
--- a/package/network/ipv6/map/Makefile
+++ b/package/network/ipv6/map/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=map
PKG_VERSION:=3
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_LICENSE:=GPL-2.0
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/ipv6/map/src/mapcalc.c b/package/network/ipv6/map/src/mapcalc.c
index b4b3d736f0..b61e157fc3 100644
--- a/package/network/ipv6/map/src/mapcalc.c
+++ b/package/network/ipv6/map/src/mapcalc.c
@@ -226,6 +226,9 @@ int main(int argc, char *argv[])
if (offset < 0)
offset = (lw4o6) ? 0 : (legacy) ? 4 : 6;
+ if (lw4o6 && ealen < 0 && psidlen >= 0)
+ ealen = psidlen;
+
// Find PD
struct blob_attr *c, *cur;
unsigned rem;