summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--include/host.mk8
2 files changed, 5 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index f157b9d3a9..e97423ee63 100644
--- a/Makefile
+++ b/Makefile
@@ -20,7 +20,7 @@ all: world
SHELL:=/usr/bin/env bash
export LC_ALL=C
export LANG=C
-export TOPDIR=${shell pwd}
+export TOPDIR=${CURDIR}
ifeq ($(KBUILD_VERBOSE),99)
MAKE:=3>/dev/null $(MAKE)
endif
diff --git a/include/host.mk b/include/host.mk
index 278ad726ff..4a434711c3 100644
--- a/include/host.mk
+++ b/include/host.mk
@@ -23,11 +23,11 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
echo "HOST_OS:=$$HOST_OS" > $@; \
echo "HOST_ARCH:=$$HOST_ARCH" >> $@; \
echo "GNU_HOST_NAME:=$$GNU_HOST_NAME" >> $@; \
- TAR=`which gtar`; \
- [ -n "$$TAR" -a -x "$$TAR" ] || TAR=`which tar`; \
+ TAR=`which gtar 2>/dev/null`; \
+ [ -n "$$TAR" -a -x "$$TAR" ] || TAR=`which tar 2>/dev/null`; \
echo "TAR:=$$TAR" >> $@; \
- ZCAT=`which gzcat`; \
- [ -n "$$ZCAT" -a -x "$$ZCAT" ] || ZCAT=`which zcat`; \
+ ZCAT=`which gzcat 2>/dev/null`; \
+ [ -n "$$ZCAT" -a -x "$$ZCAT" ] || ZCAT=`which zcat 2>/dev/null`; \
echo "ZCAT:=$$ZCAT" >> $@; \
echo "BASH:=$(shell which bash)" >> $@; \
)