summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/cns3xxx/patches-3.1/049-cns3xxx_smp_support.patch2
-rw-r--r--target/linux/cns3xxx/patches-3.1/200-dwc_otg.patch2
-rw-r--r--target/linux/lantiq/Makefile2
-rw-r--r--target/linux/omap24xx/Makefile2
5 files changed, 6 insertions, 6 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 85bfe81af2..fc2203f5d0 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -32,8 +32,8 @@ endif
ifeq ($(LINUX_VERSION),3.0.18)
LINUX_KERNEL_MD5SUM:=67252770d7009eabe8bac7c26e074f9d
endif
-ifeq ($(LINUX_VERSION),3.1.9)
- LINUX_KERNEL_MD5SUM:=4e387a49cde20805955c905bc8c311e0
+ifeq ($(LINUX_VERSION),3.1.10)
+ LINUX_KERNEL_MD5SUM:=3649bdaa50ffd9114cc16486ec54d83a
endif
ifeq ($(LINUX_VERSION),3.2.1)
LINUX_KERNEL_MD5SUM:=090eb3dae0f520f7770f85193e931ad3
diff --git a/target/linux/cns3xxx/patches-3.1/049-cns3xxx_smp_support.patch b/target/linux/cns3xxx/patches-3.1/049-cns3xxx_smp_support.patch
index 854c7fa7a6..e34134055e 100644
--- a/target/linux/cns3xxx/patches-3.1/049-cns3xxx_smp_support.patch
+++ b/target/linux/cns3xxx/patches-3.1/049-cns3xxx_smp_support.patch
@@ -404,7 +404,7 @@
+}
--- a/arch/arm/Kconfig
+++ b/arch/arm/Kconfig
-@@ -1376,7 +1376,7 @@ config SMP
+@@ -1388,7 +1388,7 @@ config SMP
depends on REALVIEW_EB_ARM11MP || REALVIEW_EB_A9MP || \
MACH_REALVIEW_PB11MP || MACH_REALVIEW_PBX || ARCH_OMAP4 || \
ARCH_EXYNOS4 || ARCH_TEGRA || ARCH_U8500 || ARCH_VEXPRESS_CA9X4 || \
diff --git a/target/linux/cns3xxx/patches-3.1/200-dwc_otg.patch b/target/linux/cns3xxx/patches-3.1/200-dwc_otg.patch
index c53189f2e7..27a97126d0 100644
--- a/target/linux/cns3xxx/patches-3.1/200-dwc_otg.patch
+++ b/target/linux/cns3xxx/patches-3.1/200-dwc_otg.patch
@@ -22654,8 +22654,8 @@
+ dma_addr_t aligned_transfer_dma;/* (in) dma addr for transfer_buffer */
+ u32 aligned_transfer_buffer_length; /* (in) data buffer length */
struct scatterlist *sg; /* (in) scatter gather buffer list */
+ int num_mapped_sgs; /* (internal) mapped sg entries */
int num_sgs; /* (in) number of entries in the sg list */
- u32 transfer_buffer_length; /* (in) data buffer length */
--- a/drivers/usb/gadget/Kconfig
+++ b/drivers/usb/gadget/Kconfig
@@ -108,7 +108,7 @@ config USB_GADGET_VBUS_DRAW
diff --git a/target/linux/lantiq/Makefile b/target/linux/lantiq/Makefile
index dced25ffdd..b0bed09dfd 100644
--- a/target/linux/lantiq/Makefile
+++ b/target/linux/lantiq/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Lantiq GPON/XWAY
FEATURES:=squashfs jffs2
DEFAULT_SUBTARGET:=danube
-LINUX_VERSION:=3.1.9
+LINUX_VERSION:=3.1.10
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
diff --git a/target/linux/omap24xx/Makefile b/target/linux/omap24xx/Makefile
index 087c707754..1188a9c087 100644
--- a/target/linux/omap24xx/Makefile
+++ b/target/linux/omap24xx/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=TI OMAP-24xx
MAINTAINER:=Michael Buesch <m@bues.ch>
FEATURES:=targz squashfs jffs2 usb usbgadget display gpio audio
-LINUX_VERSION:=3.1.9
+LINUX_VERSION:=3.1.10
define Target/Description
TI OMAP-24xx