summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--tools/squashfs/Makefile1
-rw-r--r--tools/squashfs4/Makefile1
2 files changed, 2 insertions, 0 deletions
diff --git a/tools/squashfs/Makefile b/tools/squashfs/Makefile
index 473c526510..c6ad3dd1be 100644
--- a/tools/squashfs/Makefile
+++ b/tools/squashfs/Makefile
@@ -20,6 +20,7 @@ include $(INCLUDE_DIR)/host-build.mk
define Host/Compile
$(MAKE) -C $(HOST_BUILD_DIR)/squashfs-tools \
+ CC="$(HOSTCC)" \
LZMAPATH=$(STAGING_DIR_HOST)/lib \
mksquashfs-lzma unsquashfs-lzma
endef
diff --git a/tools/squashfs4/Makefile b/tools/squashfs4/Makefile
index 04a5456f6c..fff550234c 100644
--- a/tools/squashfs4/Makefile
+++ b/tools/squashfs4/Makefile
@@ -20,6 +20,7 @@ include $(INCLUDE_DIR)/host-build.mk
define Host/Compile
$(MAKE) -C $(HOST_BUILD_DIR)/squashfs-tools \
+ CC="$(HOSTCC)" \
XZ_SUPPORT=1 \
LZMA_XZ_SUPPORT=1 \
XATTR_SUPPORT= \