summaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorWaldemar Brodkorb <wbx@openadk.org>2016-05-25 23:47:09 +0200
committerFelix Fietkau <nbd@nbd.name>2016-06-07 08:58:41 +0200
commitf7fb6e49f214e8a38698bab4d33551addbc04439 (patch)
treeb4467100750ac582fc27a0e2ed86a9c498257a5d /tools
parent4c5a49031eb690f1f311c9e8d4c68c541fadf5ae (diff)
downloadmaster-31e0f0ae-f7fb6e49f214e8a38698bab4d33551addbc04439.tar.gz
master-31e0f0ae-f7fb6e49f214e8a38698bab4d33551addbc04439.tar.bz2
master-31e0f0ae-f7fb6e49f214e8a38698bab4d33551addbc04439.zip
build: allow to build LEDE on latest MacOS X
Latest Xcode doesn't include openssl anymore. To compile mkimage from u-boot source you need SSL headers on your host. This patch provides libressl host package for any Darwin compilation. Unfortunately openssl from MacPorts can not be used, as the installed headers in /opt/local are breaking GDB compilation. Tested with a RB532 image build and resulting kernel booted on a device via TFTP. Signed-off-by: Waldemar Brodkorb <wbx@openadk.org> Signed-off-by: Felix Fietkau <nbd@nbd.name> [fixes, dependencies]
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile5
-rw-r--r--tools/libressl/Makefile22
2 files changed, 27 insertions, 0 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 187655e7fd..690e13c0ae 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -77,6 +77,11 @@ $(curdir)/bc/compile := $(curdir)/bison/install
$(curdir)/findutils/compile := $(curdir)/bison/install
$(curdir)/gengetopt/compile := $(curdir)/libtool/install
$(curdir)/patchelf/compile := $(curdir)/libtool/install
+ifeq ($(HOST_OS),Darwin)
+tools-y += libressl
+$(curdir)/mkimage/compile += $(curdir)/libressl/install
+$(curdir)/firmware-utils/compile += $(curdir)/libressl/install
+endif
ifneq ($(CONFIG_CCACHE)$(CONFIG_SDK),)
$(foreach tool, $(filter-out patch,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/install))
diff --git a/tools/libressl/Makefile b/tools/libressl/Makefile
new file mode 100644
index 0000000000..bdf34d3138
--- /dev/null
+++ b/tools/libressl/Makefile
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2016 LEDE project
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libressl
+PKG_VERSION:=2.3.4
+PKG_MD5SUM:=b81d990b7eceb156df6eaa7e9f4a353e
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+$(eval $(call HostBuild))