summaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2016-08-15 11:22:21 +0300
committerJohn Crispin <john@phrozen.org>2016-08-15 15:32:37 +0200
commita247e26a7e3f7562e875c01df02b68cb61920d7d (patch)
tree5bc17bc8a67064a017eee78df20a3fa39693b666 /tools
parent785cdc3cf24fbde6be47d609e1b363c313affca1 (diff)
downloadmaster-31e0f0ae-a247e26a7e3f7562e875c01df02b68cb61920d7d.tar.gz
master-31e0f0ae-a247e26a7e3f7562e875c01df02b68cb61920d7d.tar.bz2
master-31e0f0ae-a247e26a7e3f7562e875c01df02b68cb61920d7d.zip
tools/cmake: update to 3.6.1
Update cmake to 3.6.1 Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Diffstat (limited to 'tools')
-rw-r--r--tools/cmake/Makefile6
-rw-r--r--tools/cmake/patches/100-disable_qt_tests.patch6
-rw-r--r--tools/cmake/patches/110-freebsd-compat.patch2
3 files changed, 7 insertions, 7 deletions
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
index aaa3b33f4f..7de0bd8183 100644
--- a/tools/cmake/Makefile
+++ b/tools/cmake/Makefile
@@ -7,12 +7,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=cmake
-PKG_VERSION:=3.5.2
+PKG_VERSION:=3.6.1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://cmake.org/files/v3.5/ \
+PKG_SOURCE_URL:=https://cmake.org/files/v3.6/ \
https://fossies.org/linux/misc/
-PKG_MD5SUM:=701386a1b5ec95f8d1075ecf96383e02
+PKG_MD5SUM:=d6dd661380adacdb12f41b926ec99545
HOST_BUILD_PARALLEL:=1
HOST_CONFIGURE_PARALLEL:=1
diff --git a/tools/cmake/patches/100-disable_qt_tests.patch b/tools/cmake/patches/100-disable_qt_tests.patch
index 9d2f641041..a4c7b7e795 100644
--- a/tools/cmake/patches/100-disable_qt_tests.patch
+++ b/tools/cmake/patches/100-disable_qt_tests.patch
@@ -1,8 +1,8 @@
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
-@@ -217,15 +217,6 @@ add_RunCMake_test(interface_library)
- add_RunCMake_test(no_install_prefix)
+@@ -219,15 +219,6 @@ add_RunCMake_test(no_install_prefix)
add_RunCMake_test(configure_file)
+ add_RunCMake_test(CTestTimeoutAfterMatch)
-find_package(Qt4 QUIET)
-find_package(Qt5Core QUIET)
@@ -18,7 +18,7 @@
add_RunCMake_test(FindPkgConfig)
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
-@@ -389,10 +389,6 @@ if(BUILD_TESTING)
+@@ -392,10 +392,6 @@ if(BUILD_TESTING)
list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
diff --git a/tools/cmake/patches/110-freebsd-compat.patch b/tools/cmake/patches/110-freebsd-compat.patch
index 49c9b7809d..b7419d0bb5 100644
--- a/tools/cmake/patches/110-freebsd-compat.patch
+++ b/tools/cmake/patches/110-freebsd-compat.patch
@@ -21,7 +21,7 @@ Change-Id: I3b91ed7ac0e6878035aee202b3336c536cc6d2ff
--- a/Source/kwsys/SystemInformation.cxx
+++ b/Source/kwsys/SystemInformation.cxx
-@@ -90,6 +90,15 @@ typedef int siginfo_t;
+@@ -89,6 +89,15 @@ typedef int siginfo_t;
# include <ifaddrs.h>
# define KWSYS_SYSTEMINFORMATION_IMPLEMENT_FQDN
# endif