summaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-11-21 21:26:02 +0000
committerJohn Crispin <john@openwrt.org>2015-11-21 21:26:02 +0000
commit9ffd80fef5db275efe56703ba98dcbbb4f390164 (patch)
treef1a452b54e989a94fff32866a974e20820934068 /tools
parent058275197bbd3734e923aaabe58cab61cc291634 (diff)
downloadmaster-31e0f0ae-9ffd80fef5db275efe56703ba98dcbbb4f390164.tar.gz
master-31e0f0ae-9ffd80fef5db275efe56703ba98dcbbb4f390164.tar.bz2
master-31e0f0ae-9ffd80fef5db275efe56703ba98dcbbb4f390164.zip
tools/cmake: update to 3.4.0
Update cmake to 3.4.0. Refresh patches. Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi> SVN-Revision: 47568
Diffstat (limited to 'tools')
-rw-r--r--tools/cmake/Makefile6
-rw-r--r--tools/cmake/patches/100-disable_qt_tests.patch4
-rw-r--r--tools/cmake/patches/110-freebsd-compat.patch2
3 files changed, 6 insertions, 6 deletions
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
index b71f1af626..fab2be6fa1 100644
--- a/tools/cmake/Makefile
+++ b/tools/cmake/Makefile
@@ -7,12 +7,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=cmake
-PKG_VERSION:=3.3.2
+PKG_VERSION:=3.4.0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.cmake.org/files/v3.3/ \
+PKG_SOURCE_URL:=http://www.cmake.org/files/v3.4/ \
https://fossies.org/linux/misc/
-PKG_MD5SUM:=5febbd11bcaac854a27eebaf4a124be2
+PKG_MD5SUM:=cd3034e0a44256a0917e254167217fc8
HOST_BUILD_PARALLEL:=1
HOST_CONFIGURE_PARALLEL:=1
diff --git a/tools/cmake/patches/100-disable_qt_tests.patch b/tools/cmake/patches/100-disable_qt_tests.patch
index deaa5ae48c..417e27afab 100644
--- a/tools/cmake/patches/100-disable_qt_tests.patch
+++ b/tools/cmake/patches/100-disable_qt_tests.patch
@@ -1,6 +1,6 @@
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
-@@ -160,15 +160,6 @@
+@@ -216,15 +216,6 @@
add_RunCMake_test(no_install_prefix)
add_RunCMake_test(configure_file)
@@ -18,7 +18,7 @@
add_RunCMake_test(FindPkgConfig)
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
-@@ -358,10 +358,6 @@
+@@ -390,10 +390,6 @@
list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
diff --git a/tools/cmake/patches/110-freebsd-compat.patch b/tools/cmake/patches/110-freebsd-compat.patch
index 9133db5038..b54944829b 100644
--- a/tools/cmake/patches/110-freebsd-compat.patch
+++ b/tools/cmake/patches/110-freebsd-compat.patch
@@ -23,7 +23,7 @@ diff --git a/Source/kwsys/SystemInformation.cxx b/Source/kwsys/SystemInformation
index 7c31f3a..2672730 100644
--- a/Source/kwsys/SystemInformation.cxx
+++ b/Source/kwsys/SystemInformation.cxx
-@@ -91,6 +91,15 @@ typedef int siginfo_t;
+@@ -90,6 +90,15 @@ typedef int siginfo_t;
# include <ifaddrs.h>
# define KWSYS_SYSTEMINFORMATION_IMPLEMENT_FQDN
# endif