summaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2016-06-15 18:54:02 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2016-06-15 19:26:17 +0200
commit96db10752483cb07f822686482b44be6c21fbb5f (patch)
tree7d8b084b244634660722079820bbb1edaeea7a4c /tools
parent6fb212f2933bbbdf2935124205717c9d0ca72b32 (diff)
downloadmaster-31e0f0ae-96db10752483cb07f822686482b44be6c21fbb5f.tar.gz
master-31e0f0ae-96db10752483cb07f822686482b44be6c21fbb5f.tar.bz2
master-31e0f0ae-96db10752483cb07f822686482b44be6c21fbb5f.zip
tools/cmake: fix parallel build with Make 4.2+
Avoid using the --parallel argument to the CMake bootstrap, as that doesn't allow us to remove the -j argument. Instead, pass the HOST_JOBS arguments in MAKEFLAGS. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'tools')
-rw-r--r--tools/cmake/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
index da62f70745..aaa3b33f4f 100644
--- a/tools/cmake/Makefile
+++ b/tools/cmake/Makefile
@@ -19,10 +19,11 @@ HOST_CONFIGURE_PARALLEL:=1
include $(INCLUDE_DIR)/host-build.mk
+HOST_CONFIGURE_CMD := MAKEFLAGS="$(HOST_JOBS)" $(BASH) ./configure
+
HOST_CONFIGURE_VARS :=
HOST_CONFIGURE_ARGS := \
- --prefix=$(STAGING_DIR_HOST) \
- $(if $(MAKE_JOBSERVER),--parallel="$(MAKE_JOBSERVER)")
+ --prefix=$(STAGING_DIR_HOST)
$(eval $(call HostBuild))