summaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2016-04-17 12:52:37 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2016-04-17 12:52:37 +0000
commit5a5657cda118b8d98577da39715943beb995dd9f (patch)
tree30c2fccb02abe69d279b31cf30ffc7febcbbd732 /tools
parent70e30d322bb70770ab48fa6f38ea2b79b5c73620 (diff)
downloadmaster-31e0f0ae-5a5657cda118b8d98577da39715943beb995dd9f.tar.gz
master-31e0f0ae-5a5657cda118b8d98577da39715943beb995dd9f.tar.bz2
master-31e0f0ae-5a5657cda118b8d98577da39715943beb995dd9f.zip
tools/cmake: update to 3.5.1
Update cmake to 3.5.1 Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi> Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 49186
Diffstat (limited to 'tools')
-rw-r--r--tools/cmake/Makefile6
-rw-r--r--tools/cmake/patches/100-disable_qt_tests.patch4
-rw-r--r--tools/cmake/patches/110-freebsd-compat.patch3
3 files changed, 5 insertions, 8 deletions
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
index d7a68ea810..3cbc09ea15 100644
--- a/tools/cmake/Makefile
+++ b/tools/cmake/Makefile
@@ -7,12 +7,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=cmake
-PKG_VERSION:=3.4.3
+PKG_VERSION:=3.5.1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://cmake.org/files/v3.4/ \
+PKG_SOURCE_URL:=https://cmake.org/files/v3.5/ \
https://fossies.org/linux/misc/
-PKG_MD5SUM:=4cb3ff35b2472aae70f542116d616e63
+PKG_MD5SUM:=ca051f4a66375c89d1a524e726da0296
HOST_BUILD_PARALLEL:=1
HOST_CONFIGURE_PARALLEL:=1
diff --git a/tools/cmake/patches/100-disable_qt_tests.patch b/tools/cmake/patches/100-disable_qt_tests.patch
index 417e27afab..9d2f641041 100644
--- a/tools/cmake/patches/100-disable_qt_tests.patch
+++ b/tools/cmake/patches/100-disable_qt_tests.patch
@@ -1,6 +1,6 @@
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
-@@ -216,15 +216,6 @@
+@@ -217,15 +217,6 @@ add_RunCMake_test(interface_library)
add_RunCMake_test(no_install_prefix)
add_RunCMake_test(configure_file)
@@ -18,7 +18,7 @@
add_RunCMake_test(FindPkgConfig)
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
-@@ -390,10 +390,6 @@
+@@ -389,10 +389,6 @@ if(BUILD_TESTING)
list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
diff --git a/tools/cmake/patches/110-freebsd-compat.patch b/tools/cmake/patches/110-freebsd-compat.patch
index b54944829b..49c9b7809d 100644
--- a/tools/cmake/patches/110-freebsd-compat.patch
+++ b/tools/cmake/patches/110-freebsd-compat.patch
@@ -19,8 +19,6 @@ Change-Id: I3b91ed7ac0e6878035aee202b3336c536cc6d2ff
Source/kwsys/SystemInformation.cxx | 9 +++++++++
1 file changed, 9 insertions(+)
-diff --git a/Source/kwsys/SystemInformation.cxx b/Source/kwsys/SystemInformation.cxx
-index 7c31f3a..2672730 100644
--- a/Source/kwsys/SystemInformation.cxx
+++ b/Source/kwsys/SystemInformation.cxx
@@ -90,6 +90,15 @@ typedef int siginfo_t;
@@ -39,4 +37,3 @@ index 7c31f3a..2672730 100644
#endif
#if defined(__OpenBSD__) || defined(__NetBSD__)
-