summaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-01-21 11:58:17 +0000
committerNicolas Thill <nico@openwrt.org>2009-01-21 11:58:17 +0000
commitec7b663c86839b2ddc42b27fc472dfc1fbf0ebb8 (patch)
tree1aac0de5ad5bfbab6dc9c8965a1fafbbfe774e43 /tools
parenta271aaa2dbe04f5ae79b9b5783def34b51c9cd82 (diff)
downloadmaster-31e0f0ae-ec7b663c86839b2ddc42b27fc472dfc1fbf0ebb8.tar.gz
master-31e0f0ae-ec7b663c86839b2ddc42b27fc472dfc1fbf0ebb8.tar.bz2
master-31e0f0ae-ec7b663c86839b2ddc42b27fc472dfc1fbf0ebb8.zip
add support for gcc v4.3.1 & v4.3.2 (closes: #3479), thanks to Luigi Mantellini!
SVN-Revision: 14131
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile2
-rw-r--r--tools/gmp/Makefile42
-rw-r--r--tools/mpfr/Makefile41
3 files changed, 84 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index ecde1191ba..81c69b404f 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -9,7 +9,7 @@
curdir:=tools
# subdirectories to descend into
-$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config automake $(if $(CONFIG_CCACHE),ccache) bison $(if $(CONFIG_powerpc),dtc) lua quilt autoconf
+$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config automake $(if $(CONFIG_CCACHE),ccache) bison $(if $(CONFIG_powerpc),dtc) lua quilt autoconf gmp mpfr
# builddir dependencies
$(curdir)/squashfs/compile := $(curdir)/lzma/install
diff --git a/tools/gmp/Makefile b/tools/gmp/Makefile
new file mode 100644
index 0000000000..42646716b5
--- /dev/null
+++ b/tools/gmp/Makefile
@@ -0,0 +1,42 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gmp
+PKG_VERSION:=4.2.4
+
+PKG_SOURCE_URL:=@GNU/gmp/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Build/Configure
+ (cd $(PKG_BUILD_DIR); \
+ ./configure \
+ --prefix=$(STAGING_DIR_HOST) \
+ --build=$(GNU_HOST_NAME) \
+ --enable-static \
+ --disable-shared \
+ --enable-cxx \
+ --enable-mpbsd \
+ );
+endef
+
+define Build/Compile
+ make -C $(PKG_BUILD_DIR) all
+endef
+
+define Build/Install
+ make -C $(PKG_BUILD_DIR) install
+endef
+
+define Build/Clean
+ rm -rf $(PKG_BUILD_DIR)
+endef
+
+$(eval $(call HostBuild))
diff --git a/tools/mpfr/Makefile b/tools/mpfr/Makefile
new file mode 100644
index 0000000000..84dc9ec29f
--- /dev/null
+++ b/tools/mpfr/Makefile
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mpfr
+PKG_VERSION:=2.3.2
+
+PKG_SOURCE_URL:=http://www.mpfr.org/mpfr-current/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=527147c097874340cb9cee0579dacf3b
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Build/Configure
+ (cd $(PKG_BUILD_DIR); \
+ ./configure \
+ --prefix=$(STAGING_DIR_HOST) \
+ --build=$(GNU_HOST_NAME) \
+ --enable-static \
+ --disable-shared \
+ --with-gmp=$(STAGING_DIR_HOST) \
+ );
+endef
+
+define Build/Compile
+ make -C $(PKG_BUILD_DIR) all
+endef
+
+define Build/Install
+ make -C $(PKG_BUILD_DIR) install
+endef
+
+define Build/Clean
+ rm -rf $(PKG_BUILD_DIR)
+endef
+
+$(eval $(call HostBuild))