summaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-28 13:29:03 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-28 13:29:03 +0000
commite143bed1f19b55c5eac38d78a5c98f478fca88fc (patch)
tree1f3f129a7786dd35da2414d624e8302cbdf08d7a /tools
parent9c88ba80b9d566ab7e3dc752fa68ae82aed54212 (diff)
downloadmaster-31e0f0ae-e143bed1f19b55c5eac38d78a5c98f478fca88fc.tar.gz
master-31e0f0ae-e143bed1f19b55c5eac38d78a5c98f478fca88fc.tar.bz2
master-31e0f0ae-e143bed1f19b55c5eac38d78a5c98f478fca88fc.zip
build system fixes, more cleanup
SVN-Revision: 8207
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 49b30be44b..ed2eae89d9 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -7,25 +7,25 @@
# Main makefile for the host tools
#
-curdir:=$(patsubst %/Makefile,%,$(lastword $(MAKEFILE_LIST)))
+curdir:=tools
# subdirectories to descend into
-$(curdir)/builddirs := sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline $(if $(CONFIG_CCACHE),ccache)
+tools/builddirs := sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline $(if $(CONFIG_CCACHE),ccache)
# builddir dependencies
-$(curdir)/squashfs/compile := $(curdir)/lzma/install
+tools/squashfs/compile := tools/lzma/install
# preparatory work
$(STAGING_DIR)/include-host/.done:
@mkdir -p $$(dirname $@)
- @cp $(curdir)/include/*.h $$(dirname $@)/
+ @cp tools/include/*.h $$(dirname $@)/
@touch $@
# prerequisites for the individual targets
-$(curdir)/ := .config
-$(curdir)//prepare = $(STAGING_DIR)/include-host/.done
-$(curdir)//compile = $(1)/prepare
-$(curdir)//install = $(1)/compile
+tools/ := .config
+tools//prepare = $(STAGING_DIR)/include-host/.done
+tools//compile = $(1)/prepare
+tools//install = $(1)/compile
-$(eval $(call stampfile,$(curdir),tools))
-$(eval $(call subdir,$(curdir)))
+$(eval $(call stampfile,tools,tools))
+$(eval $(call subdir,tools))