summaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-09-03 13:25:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-09-03 13:25:26 +0000
commitc6736f006ee59c4aaa4fba7f23c81b3da5e042c4 (patch)
treed990e9902dadb60c9e5e7d681315257d0be652ca /tools
parent3b937f85e807ef0d5936f87e9f18c8aef61a4176 (diff)
downloadmaster-31e0f0ae-c6736f006ee59c4aaa4fba7f23c81b3da5e042c4.tar.gz
master-31e0f0ae-c6736f006ee59c4aaa4fba7f23c81b3da5e042c4.tar.bz2
master-31e0f0ae-c6736f006ee59c4aaa4fba7f23c81b3da5e042c4.zip
fix shell return status of the find symlink command
SVN-Revision: 12514
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index e15f061a4d..ecde1191ba 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -38,7 +38,9 @@ $(STAGING_DIR_HOST)/bin/md5sum: $(STAGING_DIR)/.prepared
fi
$(STAGING_DIR_HOST)/bin/find: $(STAGING_DIR)/.prepared
- [ -x "$(FIND)" -a "$(FIND)" != "$@" ] && ln -sf "$(FIND)" $@
+ if [ -x "$(FIND)" -a "$(FIND)" != "$@" ]; then \
+ ln -sf "$(FIND)" $@; \
+ fi
$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,find md5sum)