summaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-03-09 14:44:23 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-03-09 14:44:23 +0000
commitb5a0fd29619b41c9e188f442fee67fb80df78557 (patch)
treedab495047ccd870c8c39541fcd3578bf85d2b273 /tools
parentf67f66bb89d36eb3b57161a304d6dbdc96b4d072 (diff)
downloadmaster-31e0f0ae-b5a0fd29619b41c9e188f442fee67fb80df78557.tar.gz
master-31e0f0ae-b5a0fd29619b41c9e188f442fee67fb80df78557.tar.bz2
master-31e0f0ae-b5a0fd29619b41c9e188f442fee67fb80df78557.zip
package xfce-macros, required for autoreconf in xfce4 packages
SVN-Revision: 25974
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile3
-rw-r--r--tools/xfce-macros/Makefile32
2 files changed, 34 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 6479162c50..149e3cea83 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -17,7 +17,7 @@ endif
tools-y += m4 libtool autoconf automake flex bison pkg-config sed mklibs
tools-y += sstrip ipkg-utils genext2fs e2fsprogs mtd-utils mkimage
tools-y += firmware-utils patch-cmdline quilt yaffs2 flock
-tools-y += mm-macros xorg-macros missing-macros xz cmake
+tools-y += mm-macros xorg-macros xfce-macros missing-macros xz cmake
tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
tools-$(CONFIG_TARGET_x86) += qemu
ifneq ($(CONFIG_TARGET_ar71xx),)
@@ -54,6 +54,7 @@ $(curdir)/qemu/compile := $(curdir)/e2fsprogs/install
$(curdir)/upslug2/compile := $(curdir)/automake/install
$(curdir)/mm-macros/compile := $(curdir)/automake/install
$(curdir)/xorg-macros/compile := $(curdir)/automake/install
+$(curdir)/xfce-macros/compile := $(curdir)/automake/install
$(curdir)/missing-macros/compile := $(curdir)/automake/install
$(curdir)/e2fsprogs/compile := $(curdir)/automake/install
$(curdir)/libelf/compile := $(curdir)/automake/install
diff --git a/tools/xfce-macros/Makefile b/tools/xfce-macros/Makefile
new file mode 100644
index 0000000000..bd71913d22
--- /dev/null
+++ b/tools/xfce-macros/Makefile
@@ -0,0 +1,32 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=xfce-macros
+PKG_VERSION:=4.8.0
+
+PKG_SOURCE_URL:=http://archive.xfce.org/xfce/4.8/src
+PKG_SOURCE:=xfce4-dev-tools-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=9591299c49d92d00ba47974c42a735fa
+
+HOST_BUILD_DIR:=$(BUILD_DIR)/xfce4-dev-tools-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Configure
+endef
+
+define Host/Compile
+endef
+
+define Host/Install
+ $(INSTALL_DIR) $(STAGING_DIR_HOST)/share/aclocal
+ $(INSTALL_DATA) $(HOST_BUILD_DIR)/m4macros/*.m4 $(STAGING_DIR_HOST)/share/aclocal/
+endef
+
+$(eval $(call HostBuild))