summaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-10-20 06:29:38 +0000
committerJohn Crispin <john@openwrt.org>2014-10-20 06:29:38 +0000
commit6e1637f8fab37ef233ee43ade761cb4e4962ab9a (patch)
treeab4cc51a5492b9630d8967fe1c6a67979937f884 /tools
parentc8ad508d37297400364ee276733de90d29e94778 (diff)
downloadmaster-31e0f0ae-6e1637f8fab37ef233ee43ade761cb4e4962ab9a.tar.gz
master-31e0f0ae-6e1637f8fab37ef233ee43ade761cb4e4962ab9a.tar.bz2
master-31e0f0ae-6e1637f8fab37ef233ee43ade761cb4e4962ab9a.zip
firmware-utils: restore compilation of mkhilinkfw.
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com> SVN-Revision: 42989
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile1
-rw-r--r--tools/firmware-utils/Makefile4
2 files changed, 3 insertions, 2 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 562925160f..9879be1b2c 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -72,6 +72,7 @@ $(curdir)/b43-tools/compile := $(curdir)/bison/install
$(curdir)/padjffs2/compile := $(curdir)/findutils/install
$(curdir)/cloog/compile := $(curdir)/ppl/install
$(curdir)/bc/compile := $(curdir)/bison/install
+$(curdir)/firmware-utils/compile := package/openssl/host/install
ifneq ($(CONFIG_CCACHE),)
$(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/install))
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index 4bb53cbb3f..65b7c1530e 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/kernel.mk
define cc
- $(HOSTCC) $(HOST_CFLAGS) -include endian.h $(HOST_STATIC_LINKING) -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) $(foreach src,$(1),src/$(src).c) $(2)
+ $(HOSTCC) $(HOST_CFLAGS) -include endian.h $(HOST_STATIC_LINKING) $(HOST_LDFLAGS) -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) $(foreach src,$(1),src/$(src).c) $(2)
endef
define Host/Compile
@@ -65,7 +65,7 @@ define Host/Compile
$(call cc,fix-u-media-header cyg_crc32,-Wall)
$(call cc,hcsmakeimage bcmalgo)
$(call cc,mkporayfw, -Wall)
- #$(call cc,mkhilinkfw, -lcrypto)
+ $(call cc,mkhilinkfw, -lcrypto)
$(call cc,mkdcs932, -Wall)
$(call cc,mkheader_gemtek,-lz)
$(call cc,mkrtn56uimg, -lz)