summaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-04-19 15:43:08 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-04-19 15:43:08 +0000
commit6d59a298e848fc0638920e711b1481b4b7afa18c (patch)
treeba394c3a3587ba2faec9cff7415788c192ca6d3b /tools
parent26cd3eed25919ae06ed6bb1106b1d65a00aae8eb (diff)
downloadmaster-31e0f0ae-6d59a298e848fc0638920e711b1481b4b7afa18c.tar.gz
master-31e0f0ae-6d59a298e848fc0638920e711b1481b4b7afa18c.tar.bz2
master-31e0f0ae-6d59a298e848fc0638920e711b1481b4b7afa18c.zip
add gcc-4.5.0 preliminary support
SVN-Revision: 21033
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile5
-rw-r--r--tools/mpc/Makefile40
-rw-r--r--tools/mpfr/Makefile4
-rw-r--r--tools/mpfr/patches/001-no_tests.patch12
4 files changed, 53 insertions, 8 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 8fc2da3d96..cad5011c30 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -11,8 +11,12 @@ curdir:=tools
# subdirectories to descend into
tools-y :=
ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
+ifeq ($(CONFIG_GCC_VERSION_4_5),y)
+tools-$(CONFIG_GCC_VERSION_4_5) += gmp mpfr mpc
+else
tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4) += gmp mpfr
endif
+endif
tools-y += m4 autoconf automake bison pkg-config sed mklibs
tools-y += sstrip ipkg-utils genext2fs libuuid mtd-utils mkimage
tools-y += firmware-utils patch-cmdline quilt yaffs2
@@ -40,6 +44,7 @@ $(curdir)/quilt/compile := $(curdir)/sed/install
$(curdir)/dtc/compile := $(curdir)/bison/install
$(curdir)/autoconf/compile := $(curdir)/m4/install
$(curdir)/automake/compile := $(curdir)/m4/install $(curdir)/autoconf/install
+$(curdir)/mpc/compile := $(curdir)/gmp/install
$(curdir)/mpfr/compile := $(curdir)/gmp/install
$(curdir)/mtd-utils/compile := $(curdir)/libuuid/install
diff --git a/tools/mpc/Makefile b/tools/mpc/Makefile
new file mode 100644
index 0000000000..3898830c0b
--- /dev/null
+++ b/tools/mpc/Makefile
@@ -0,0 +1,40 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mpc
+PKG_VERSION:=0.8.1
+
+PKG_SOURCE_URL:=http://www.multiprecision.org/mpc/download/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=5b34aa804d514cc295414a963aedb6bf
+
+include $(INCLUDE_DIR)/host-build.mk
+
+unexport CFLAGS
+
+ifeq ($(HOST_OS),Darwin)
+ GNU_HOST_NAME:=
+ HOST_CONFIGURE_ARGS:=$(filter-out --target= --build= --host=,$(HOST_CONFIGURE_ARGS))
+endif
+
+HOST_CONFIGURE_ARGS += \
+ --enable-static \
+ --disable-shared \
+ --with-mpfr=$(TOPDIR)/staging_dir/host \
+ --with-gmp=$(TOPDIR)/staging_dir/host
+
+define Host/Configure
+ (cd $(HOST_BUILD_DIR)/$(3); \
+ $(HOST_CONFIGURE_CMD) \
+ $(HOST_CONFIGURE_VARS) \
+ $(HOST_CONFIGURE_ARGS); \
+ )
+endef
+
+
+$(eval $(call HostBuild))
diff --git a/tools/mpfr/Makefile b/tools/mpfr/Makefile
index e986719830..ed5154f479 100644
--- a/tools/mpfr/Makefile
+++ b/tools/mpfr/Makefile
@@ -7,11 +7,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mpfr
-PKG_VERSION:=2.4.1
+PKG_VERSION:=2.4.2
PKG_SOURCE_URL:=http://www.mpfr.org/mpfr-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=c5ee0a8ce82ad55fe29ac57edd35d09e
+PKG_MD5SUM:=89e59fe665e2b3ad44a6789f40b059a0
include $(INCLUDE_DIR)/host-build.mk
diff --git a/tools/mpfr/patches/001-no_tests.patch b/tools/mpfr/patches/001-no_tests.patch
index e1a6f05c12..de69a83ab8 100644
--- a/tools/mpfr/patches/001-no_tests.patch
+++ b/tools/mpfr/patches/001-no_tests.patch
@@ -7,18 +7,18 @@ diff -urN mpfr-2.4.1/Makefile.am mpfr-2.4.1.new/Makefile.am
-SUBDIRS = tests
+SUBDIRS =
- EXTRA_DIST = BUGS FAQ.html PATCHES VERSION get_patches.sh round_raw_generic.c gen_inverse.h jyn_asympt.c
- include_HEADERS = mpfr.h mpf2mpfr.h
+ nobase_dist_doc_DATA = AUTHORS BUGS COPYING COPYING.LIB FAQ.html NEWS TODO \
+ examples/ReadMe examples/divworst.c examples/rndo-add.c examples/sample.c
diff -urN mpfr-2.4.1/Makefile.in mpfr-2.4.1.new/Makefile.in
--- mpfr-2.4.1/Makefile.in 2009-02-25 17:18:06.000000000 +0100
+++ mpfr-2.4.1.new/Makefile.in 2009-08-20 14:58:32.000000000 +0200
-@@ -295,7 +295,7 @@
+@@ -344,7 +344,7 @@
top_srcdir = @top_srcdir@
AUTOMAKE_OPTIONS = gnu ansi2knr
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = tests
+SUBDIRS =
- EXTRA_DIST = BUGS FAQ.html PATCHES VERSION get_patches.sh round_raw_generic.c gen_inverse.h jyn_asympt.c
- include_HEADERS = mpfr.h mpf2mpfr.h
- lib_LTLIBRARIES = libmpfr.la
+ nobase_dist_doc_DATA = AUTHORS BUGS COPYING COPYING.LIB FAQ.html NEWS TODO \
+ examples/ReadMe examples/divworst.c examples/rndo-add.c examples/sample.c
+