summaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-13 11:35:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-13 11:35:37 +0000
commit3d41dbae65fb3d5103dd0a7d6178c4990596b3db (patch)
treebd2aa67d88efe69998d385a796a1d723d04e6609 /tools
parentedd87061ec872ea539e95bcea71c80e2fc5bc3d4 (diff)
downloadmaster-31e0f0ae-3d41dbae65fb3d5103dd0a7d6178c4990596b3db.tar.gz
master-31e0f0ae-3d41dbae65fb3d5103dd0a7d6178c4990596b3db.tar.bz2
master-31e0f0ae-3d41dbae65fb3d5103dd0a7d6178c4990596b3db.zip
tools: add isl (used for graphite on GCC 5)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 47464
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile14
-rw-r--r--tools/isl/Makefile27
2 files changed, 37 insertions, 4 deletions
diff --git a/tools/Makefile b/tools/Makefile
index df384d4a90..346f0e9f38 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -13,10 +13,14 @@ tools-y :=
ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
BUILD_TOOLCHAIN := y
-endif
-ifdef CONFIG_GCC_USE_GRAPHITE
- ifeq ($(CONFIG_GCC_USE_SYSTEM_PPL_CLOOG),)
- BUILD_PPL_CLOOG = y
+ ifdef CONFIG_GCC_USE_GRAPHITE
+ ifneq ($(CONFIG_GCC_VERSION_4_8),)
+ ifeq ($(CONFIG_GCC_USE_SYSTEM_PPL_CLOOG),)
+ BUILD_PPL_CLOOG = y
+ endif
+ else
+ BUILD_ISL = y
+ endif
endif
endif
ifneq ($(CONFIG_PACKAGE_kmod-b43)$(CONFIG_PACKAGE_kmod-b43legacy)$(CONFIG_BRCMSMAC_USE_FW_FROM_WL),)
@@ -37,6 +41,7 @@ tools-$(CONFIG_TARGET_ar71xx) += lzma-old squashfs
tools-y += lzma squashfs4
tools-$(BUILD_B43_TOOLS) += b43-tools
tools-$(BUILD_PPL_CLOOG) += ppl cloog
+tools-$(BUILD_ISL) += isl
tools-$(CONFIG_USE_SPARSE) += sparse
# builddir dependencies
@@ -67,6 +72,7 @@ $(curdir)/sdcc/compile := $(curdir)/bison/install
$(curdir)/b43-tools/compile := $(curdir)/bison/install
$(curdir)/padjffs2/compile := $(curdir)/findutils/install
$(curdir)/cloog/compile := $(curdir)/ppl/install
+$(curdir)/isl/compile := $(curdir)/gmp/install
$(curdir)/bc/compile := $(curdir)/bison/install
$(curdir)/findutils/compile := $(curdir)/bison/install
$(curdir)/gengetopt/compile := $(curdir)/libtool/install
diff --git a/tools/isl/Makefile b/tools/isl/Makefile
new file mode 100644
index 0000000000..8fe2da1a06
--- /dev/null
+++ b/tools/isl/Makefile
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2009-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=isl
+PKG_VERSION:=0.14.1
+
+PKG_SOURCE_URL:=http://isl.gforge.inria.fr
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_MD5SUM:=94fcd11e0b1c79250ae341affb1845ea
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+unexport CFLAGS
+
+HOST_CONFIGURE_ARGS += \
+ --enable-static \
+ --disable-shared \
+ --with-gmp-prefix=$(STAGING_DIR_HOST)
+
+$(eval $(call HostBuild))