summaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-02-20 03:25:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-02-20 03:25:56 +0000
commit11c08a39bc207e2042dabe7966595caeb0fe4834 (patch)
tree8c0e4e893a9d2e44e912f58fc5c1edeec06e1150 /tools
parentd56fe0cf5389dae4096d13eb16e3fc0d28360f88 (diff)
downloadmaster-31e0f0ae-11c08a39bc207e2042dabe7966595caeb0fe4834.tar.gz
master-31e0f0ae-11c08a39bc207e2042dabe7966595caeb0fe4834.tar.bz2
master-31e0f0ae-11c08a39bc207e2042dabe7966595caeb0fe4834.zip
tools/e2fsprogs: move uuid/uuid.h into a subdirectory, it conflicts with a system header file with the same name on darwin
SVN-Revision: 25598
Diffstat (limited to 'tools')
-rw-r--r--tools/e2fsprogs/Makefile3
-rw-r--r--tools/mtd-utils/Makefile1
-rw-r--r--tools/qemu/Makefile2
3 files changed, 6 insertions, 0 deletions
diff --git a/tools/e2fsprogs/Makefile b/tools/e2fsprogs/Makefile
index 413e965a0e..0bfcfb4f0f 100644
--- a/tools/e2fsprogs/Makefile
+++ b/tools/e2fsprogs/Makefile
@@ -30,6 +30,9 @@ CONFIGURE_ARGS += \
define Host/Install
$(Host/Install/Default)
$(MAKE) -C $(HOST_BUILD_DIR)/lib/uuid install
+ mkdir -p $(STAGING_DIR_HOST)/include/e2fsprogs
+ $(CP) $(STAGING_DIR_HOST)/include/uuid $(STAGING_DIR_HOST)/include/e2fsprogs/
+ rm -rf $(STAGING_DIR_HOST)/include/uuid
$(INSTALL_DATA) $(HOST_BUILD_DIR)/lib/uuid/libuuid.a $(STAGING_DIR_HOST)/lib/
endef
diff --git a/tools/mtd-utils/Makefile b/tools/mtd-utils/Makefile
index 7dc31f51a5..4d5117b9b7 100644
--- a/tools/mtd-utils/Makefile
+++ b/tools/mtd-utils/Makefile
@@ -21,6 +21,7 @@ HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)-$(PKG_VERSION)
include $(INCLUDE_DIR)/host-build.mk
+HOST_CFLAGS += -I$(STAGING_DIR_HOST)/include/e2fsprogs
CFLAGS := $(HOST_CFLAGS) -I$(HOST_BUILD_DIR)/include -L$(HOST_BUILD_DIR) -L$(STAGING_DIR_HOST)/lib -DNO_NATIVE_SUPPORT
ifneq ($(HOST_OS),Linux)
CFLAGS += -Dloff_t=off_t -D__BYTE_ORDER=BYTE_ORDER -include getline.h -include endian.h -I$(CURDIR)/include -include fls.h
diff --git a/tools/qemu/Makefile b/tools/qemu/Makefile
index 37a510cf92..c0d587b243 100644
--- a/tools/qemu/Makefile
+++ b/tools/qemu/Makefile
@@ -16,6 +16,8 @@ PKG_MD5SUM:=397a0d665da8ba9d3b9583629f3d6421
include $(INCLUDE_DIR)/host-build.mk
+HOST_CFLAGS += -I$(STAGING_DIR_HOST)/include/e2fsprogs
+
define Host/Configure
(cd $(HOST_BUILD_DIR); \
CFLAGS="$(HOST_CFLAGS)" \