summaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-01-31 20:15:57 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-01-31 20:15:57 +0000
commit0756895047675381ed7aa2508e6e11659c10ed0e (patch)
treeeffb1d1b81c8af01d71b7d8ca2b63719ed3212b8 /tools
parentca354290ebe11cc52f6d0002d8ef76d51eb147b8 (diff)
downloadmaster-31e0f0ae-0756895047675381ed7aa2508e6e11659c10ed0e.tar.gz
master-31e0f0ae-0756895047675381ed7aa2508e6e11659c10ed0e.tar.bz2
master-31e0f0ae-0756895047675381ed7aa2508e6e11659c10ed0e.zip
add tools/cmake
SVN-Revision: 25264
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile2
-rw-r--r--tools/cmake/Makefile18
2 files changed, 19 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index d8e7bfd8ee..cefb008a42 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -17,7 +17,7 @@ endif
tools-y += m4 libtool autoconf automake flex bison pkg-config sed mklibs
tools-y += sstrip ipkg-utils genext2fs e2fsprogs mtd-utils mkimage
tools-y += firmware-utils patch-cmdline quilt yaffs2 flock
-tools-y += mm-macros xorg-macros missing-macros xz
+tools-y += mm-macros xorg-macros missing-macros xz cmake
tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
tools-$(CONFIG_TARGET_x86) += qemu
ifneq ($(CONFIG_TARGET_ar71xx),)
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
new file mode 100644
index 0000000000..dbc2a7e124
--- /dev/null
+++ b/tools/cmake/Makefile
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=cmake
+PKG_VERSION:=2.8.3
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.cmake.org/files/v2.8/
+PKG_MD5SUM:=a76a44b93acf5e3badda9de111385921
+
+include $(INCLUDE_DIR)/host-build.mk
+
+$(eval $(call HostBuild))