summaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-02-19 17:18:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-02-19 17:18:26 +0000
commit062456ec4c5ad06f29598e3332a2d26fc0391cb1 (patch)
tree4a913a32be0b1c7f5095622f0ce76645b17266e1 /tools
parentb248acae9578400173524088965349753ceb5ce3 (diff)
downloadmaster-31e0f0ae-062456ec4c5ad06f29598e3332a2d26fc0391cb1.tar.gz
master-31e0f0ae-062456ec4c5ad06f29598e3332a2d26fc0391cb1.tar.bz2
master-31e0f0ae-062456ec4c5ad06f29598e3332a2d26fc0391cb1.zip
prefer gstat over stat if available (patch from #4571)
SVN-Revision: 14568
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index c5a9933448..c0bbcdbeea 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -39,8 +39,9 @@ endef
$(eval $(call PrepareCommand,find,gfind find))
$(eval $(call PrepareCommand,md5sum,md5sum $(SCRIPT_DIR)/md5sum))
$(eval $(call PrepareCommand,cp,gcp cp))
+$(eval $(call PrepareCommand,stat,gstat stat))
-$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,find md5sum cp)
+$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,find md5sum cp stat)
$(curdir)//prepare = $(STAGING_DIR)/.prepared $($(curdir)/cmddeps)
$(curdir)//compile = $(STAGING_DIR)/.prepared $($(curdir)/cmddeps)