summaryrefslogtreecommitdiffstats
path: root/tools/xz
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-09-14 14:03:21 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-09-14 14:03:21 +0000
commitb4e49ad8f0c75f2c3f22e6bc8a8c1af7fddff258 (patch)
tree24d2d215701392bf5edcdeea242e4bcbc792fcff /tools/xz
parent164ac62643100fd97f960b72748501ec09e99be0 (diff)
downloadmaster-31e0f0ae-b4e49ad8f0c75f2c3f22e6bc8a8c1af7fddff258.tar.gz
master-31e0f0ae-b4e49ad8f0c75f2c3f22e6bc8a8c1af7fddff258.tar.bz2
master-31e0f0ae-b4e49ad8f0c75f2c3f22e6bc8a8c1af7fddff258.zip
tools/xz: disable shared library
Force a static build of the xz utilities in order to avoid the dependency on a shared liblzma.so which might collide with the distro version. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 46907
Diffstat (limited to 'tools/xz')
-rw-r--r--tools/xz/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/tools/xz/Makefile b/tools/xz/Makefile
index e266667957..d1f10081ae 100644
--- a/tools/xz/Makefile
+++ b/tools/xz/Makefile
@@ -17,6 +17,10 @@ HOST_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/host-build.mk
+HOST_CONFIGURE_ARGS += \
+ --enable-static=yes \
+ --enable-shared=no \
+
define Host/Install
+$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat"
endef