summaryrefslogtreecommitdiffstats
path: root/tools/xorg-macros/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-12-10 10:01:45 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-12-10 10:01:45 +0000
commit96dff60461cc750379bf68748479ff148f4e91c4 (patch)
tree469a23f33c5581f4d05c6c5e717baff17175f3fe /tools/xorg-macros/Makefile
parent2104af77e3231b7e79addd32464df7b0caaedf92 (diff)
downloadmaster-31e0f0ae-96dff60461cc750379bf68748479ff148f4e91c4.tar.gz
master-31e0f0ae-96dff60461cc750379bf68748479ff148f4e91c4.tar.bz2
master-31e0f0ae-96dff60461cc750379bf68748479ff148f4e91c4.zip
package xorg-macros
SVN-Revision: 24407
Diffstat (limited to 'tools/xorg-macros/Makefile')
-rw-r--r--tools/xorg-macros/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/tools/xorg-macros/Makefile b/tools/xorg-macros/Makefile
new file mode 100644
index 0000000000..020dadb079
--- /dev/null
+++ b/tools/xorg-macros/Makefile
@@ -0,0 +1,34 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=xorg-macros
+PKG_VERSION:=1.11.0
+
+PKG_SOURCE:=util-macros-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://cgit.freedesktop.org/xorg/util/macros/snapshot/
+PKG_MD5SUM:=2bb2645cfc2cc6768dd46f9406cab1d7
+
+HOST_BUILD_DIR:=$(BUILD_DIR)/util-macros-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Compile
+ ( cd $(HOST_BUILD_DIR); ./autogen.sh )
+endef
+
+define Host/Install
+ $(INSTALL_DIR) $(STAGING_DIR)/host/share/aclocal
+ $(INSTALL_DATA) $(HOST_BUILD_DIR)/xorg-macros.m4 $(STAGING_DIR)/host/share/aclocal/
+endef
+
+define Host/Clean
+ -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))