summaryrefslogtreecommitdiffstats
path: root/tools/wrt350nv2-builder/Makefile
diff options
context:
space:
mode:
authorTravis Kemen <thepeople@openwrt.org>2010-02-12 01:40:57 +0000
committerTravis Kemen <thepeople@openwrt.org>2010-02-12 01:40:57 +0000
commitcb9c37af385c64ee07c14f6b4e634d2d4cc4ad5c (patch)
tree92ebf07ebd466001ca3f3a1c6316537868a10bf0 /tools/wrt350nv2-builder/Makefile
parent9e5844fda2400b5668188baf0ae3b7a68bb176b5 (diff)
downloadmaster-31e0f0ae-cb9c37af385c64ee07c14f6b4e634d2d4cc4ad5c.tar.gz
master-31e0f0ae-cb9c37af385c64ee07c14f6b4e634d2d4cc4ad5c.tar.bz2
master-31e0f0ae-cb9c37af385c64ee07c14f6b4e634d2d4cc4ad5c.zip
Update to v2.1 Stays closer to the stock firmware by using wrt350n.bin for the created image. Adds the possibility to create the image in two separate steps (-b / -z). Makefiles now support the possibility to include a u-boot image for a 100%-stock-like image.
Signed off by: Matthias Buecher <mail@maddes.net> SVN-Revision: 19596
Diffstat (limited to 'tools/wrt350nv2-builder/Makefile')
-rw-r--r--tools/wrt350nv2-builder/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/tools/wrt350nv2-builder/Makefile b/tools/wrt350nv2-builder/Makefile
index 648dd84db9..b07f511f07 100644
--- a/tools/wrt350nv2-builder/Makefile
+++ b/tools/wrt350nv2-builder/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=wrt350nv2-builder
-PKG_VERSION:=2.0
+PKG_VERSION:=2.1
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/${PKG_NAME}-$(PKG_VERSION)
@@ -24,10 +24,16 @@ endef
define Host/Install
$(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
$(INSTALL_BIN) $(HOST_BUILD_DIR)/wrt350nv2-builder $(STAGING_DIR_HOST)/bin/
+# optionally the builder can add a u-boot binary to create a complete webupgrade image, but this is not mandatory
+# u-boot images from stock firmware are available at ftp://ftp.maddes.net/openwrt/kamikaze/orion/stock/binaries/
+ [ ! -f "files/u-boot.bin" ] || ( \
+ $(INSTALL_DIR) $(STAGING_DIR_HOST)/share/wrt350nv2-builder; \
+ $(CP) files/u-boot.bin $(STAGING_DIR_HOST)/share/wrt350nv2-builder/; )
endef
define Host/Clean
rm -f $(STAGING_DIR_HOST)/bin/wrt350nv2-builder
+ rm -f $(STAGING_DIR_HOST)/share/wrt350nv2-builder
endef
$(eval $(call HostBuild))