summaryrefslogtreecommitdiffstats
path: root/tools/upx
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-08-12 12:34:30 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-08-12 12:34:30 +0000
commitcf1698c6370d6a64f5f70a2dc5652d1fbc62afc3 (patch)
tree8dea115df7f768723281ea58c0ce7d0c4180182b /tools/upx
parent095fe8743b64a47ea2b13642934348f914d2a2bb (diff)
downloadmaster-31e0f0ae-cf1698c6370d6a64f5f70a2dc5652d1fbc62afc3.tar.gz
master-31e0f0ae-cf1698c6370d6a64f5f70a2dc5652d1fbc62afc3.tar.bz2
master-31e0f0ae-cf1698c6370d6a64f5f70a2dc5652d1fbc62afc3.zip
use HOST_STATIC_LINKING instead of hardcoding -static
SVN-Revision: 33140
Diffstat (limited to 'tools/upx')
-rw-r--r--tools/upx/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/upx/Makefile b/tools/upx/Makefile
index 339c611154..3e76232012 100644
--- a/tools/upx/Makefile
+++ b/tools/upx/Makefile
@@ -21,7 +21,7 @@ include $(INCLUDE_DIR)/host-build.mk
define Host/Compile
rm -f $(HOST_BUILD_DIR)/src/.depend
$(MAKE) UPX_LZMADIR="$(BUILD_DIR_HOST)/lzma-4.65" -C $(HOST_BUILD_DIR)/src \
- CXXFLAGS_WERROR="" LDFLAGS="$(HOST_LDFLAGS) -static"
+ CXXFLAGS_WERROR="" LDFLAGS="$(HOST_LDFLAGS) $(HOST_STATIC_LINKING)"
endef
define Host/Install