summaryrefslogtreecommitdiffstats
path: root/tools/squashfs
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-08-12 12:34:30 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-08-12 12:34:30 +0000
commitcf1698c6370d6a64f5f70a2dc5652d1fbc62afc3 (patch)
tree8dea115df7f768723281ea58c0ce7d0c4180182b /tools/squashfs
parent095fe8743b64a47ea2b13642934348f914d2a2bb (diff)
downloadmaster-31e0f0ae-cf1698c6370d6a64f5f70a2dc5652d1fbc62afc3.tar.gz
master-31e0f0ae-cf1698c6370d6a64f5f70a2dc5652d1fbc62afc3.tar.bz2
master-31e0f0ae-cf1698c6370d6a64f5f70a2dc5652d1fbc62afc3.zip
use HOST_STATIC_LINKING instead of hardcoding -static
SVN-Revision: 33140
Diffstat (limited to 'tools/squashfs')
-rw-r--r--tools/squashfs/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/squashfs/Makefile b/tools/squashfs/Makefile
index f4a5460135..6dc27d6750 100644
--- a/tools/squashfs/Makefile
+++ b/tools/squashfs/Makefile
@@ -21,7 +21,7 @@ include $(INCLUDE_DIR)/host-build.mk
define Host/Compile
$(MAKE) -C $(HOST_BUILD_DIR)/squashfs-tools \
CC="$(HOSTCC)" \
- CXX="$(CXX) -static" \
+ CXX="$(CXX) $(HOST_STATIC_LINKING)" \
LZMAPATH=$(STAGING_DIR_HOST)/lib \
mksquashfs-lzma unsquashfs-lzma
endef