summaryrefslogtreecommitdiffstats
path: root/tools/squashfs
diff options
context:
space:
mode:
authorRalph Hempel <ralph.hempel@lantiq.com>2008-06-16 11:32:13 +0000
committerRalph Hempel <ralph.hempel@lantiq.com>2008-06-16 11:32:13 +0000
commit79bd4016bc091f29a6f53cd43c42c42897cfc78f (patch)
treef868a5902c656bc26ec8f4a9667630b7979f1a84 /tools/squashfs
parenta09998311d5695fca942670ee9928dcf2405f630 (diff)
downloadmaster-31e0f0ae-79bd4016bc091f29a6f53cd43c42c42897cfc78f.tar.gz
master-31e0f0ae-79bd4016bc091f29a6f53cd43c42c42897cfc78f.tar.bz2
master-31e0f0ae-79bd4016bc091f29a6f53cd43c42c42897cfc78f.zip
added unsquashfs-lzma, usefull for debugging of existing fs images
SVN-Revision: 11496
Diffstat (limited to 'tools/squashfs')
-rw-r--r--tools/squashfs/Makefile4
-rw-r--r--tools/squashfs/patches/100-lzma.patch11
2 files changed, 10 insertions, 5 deletions
diff --git a/tools/squashfs/Makefile b/tools/squashfs/Makefile
index d0098361f9..53baa7abfb 100644
--- a/tools/squashfs/Makefile
+++ b/tools/squashfs/Makefile
@@ -21,15 +21,17 @@ include $(INCLUDE_DIR)/host-build.mk
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR)/squashfs-tools \
LZMAPATH=$(STAGING_DIR_HOST)/lib \
- mksquashfs-lzma
+ mksquashfs-lzma unsquashfs-lzma
endef
define Build/Install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/squashfs-tools/mksquashfs-lzma $(STAGING_DIR_HOST)/bin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/squashfs-tools/unsquashfs-lzma $(STAGING_DIR_HOST)/bin/
endef
define Build/Clean
rm -f $(STAGING_DIR_HOST)/bin/mksquashfs-lzma
+ rm -f $(STAGING_DIR_HOST)/bin/unsquashfs-lzma
endef
$(eval $(call HostBuild))
diff --git a/tools/squashfs/patches/100-lzma.patch b/tools/squashfs/patches/100-lzma.patch
index 85aa21fb92..34fdcad18b 100644
--- a/tools/squashfs/patches/100-lzma.patch
+++ b/tools/squashfs/patches/100-lzma.patch
@@ -1,6 +1,5 @@
-diff -Nur squashfs3.0/squashfs-tools/Makefile squashfs3.0-owrt/squashfs-tools/Makefile
---- squashfs3.0/squashfs-tools/Makefile 2006-03-15 22:36:20.000000000 +0100
-+++ squashfs3.0-owrt/squashfs-tools/Makefile 2006-03-21 11:14:08.000000000 +0100
+--- a/squashfs-tools/Makefile
++++ b/squashfs-tools/Makefile
@@ -1,4 +1,5 @@
INCLUDEDIR = .
+#LZMAPATH = ../lzma/SRC/7zip/Compress/LZMA_Lib
@@ -17,9 +16,13 @@ diff -Nur squashfs3.0/squashfs-tools/Makefile squashfs3.0-owrt/squashfs-tools/Ma
mksquashfs.o: mksquashfs.c squashfs_fs.h mksquashfs.h global.h sort.h
read_fs.o: read_fs.c squashfs_fs.h read_fs.h global.h
-@@ -17,3 +21,5 @@
+@@ -16,4 +20,9 @@
+ unsquashfs: unsquashfs.o
$(CC) unsquashfs.o -lz -o $@
++unsquashfs-lzma: unsquashfs.o
++ $(CXX) unsquashfs.o -L$(LZMAPATH) -llzma -o $@
++
unsquashfs.o: unsquashfs.c squashfs_fs.h read_fs.h global.h
+
+clean: