summaryrefslogtreecommitdiffstats
path: root/tools/squashfs4
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-05-15 12:07:21 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-05-15 12:07:21 +0000
commit01287654f215c79c70fb7e4addc4f59d0719341b (patch)
treea5b4f9c7ee83994c578934d35360022d78b63f30 /tools/squashfs4
parente9d31c35ecff5ce2907e3c64baa6854d33dc3939 (diff)
downloadmaster-31e0f0ae-01287654f215c79c70fb7e4addc4f59d0719341b.tar.gz
master-31e0f0ae-01287654f215c79c70fb7e4addc4f59d0719341b.tar.bz2
master-31e0f0ae-01287654f215c79c70fb7e4addc4f59d0719341b.zip
add tool for squashfs4 image generation (w/o LZMA support)
SVN-Revision: 15864
Diffstat (limited to 'tools/squashfs4')
-rw-r--r--tools/squashfs4/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/tools/squashfs4/Makefile b/tools/squashfs4/Makefile
new file mode 100644
index 0000000000..f172d3bc6b
--- /dev/null
+++ b/tools/squashfs4/Makefile
@@ -0,0 +1,36 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=squashfs4
+PKG_VERSION:=4.0
+
+PKG_SOURCE:=squashfs$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/squashfs
+PKG_MD5SUM:=a3c23391da4ebab0ac4a75021ddabf96
+PKG_CAT:=zcat
+
+HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/squashfs$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Compile
+ $(MAKE) -C $(HOST_BUILD_DIR)/squashfs-tools \
+ mksquashfs unsquashfs
+endef
+
+define Host/Install
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/squashfs-tools/mksquashfs $(STAGING_DIR_HOST)/bin/mksquashfs4
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/squashfs-tools/unsquashfs $(STAGING_DIR_HOST)/bin/unsquashfs4
+endef
+
+define Host/Clean
+ rm -f $(STAGING_DIR_HOST)/bin/mksquashfs4
+ rm -f $(STAGING_DIR_HOST)/bin/unsquashfs4
+endef
+
+$(eval $(call HostBuild))