summaryrefslogtreecommitdiffstats
path: root/tools/squashfs4/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-05-17 00:57:52 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-05-17 00:57:52 +0000
commitbc152ef2c51f23916fe442924b430ad441b9d886 (patch)
treea36548da1951e27ae2afbdf5c3f0614492d6bc21 /tools/squashfs4/Makefile
parent9da8f2b2a0bfe1e39ab469769a7af9834fb706eb (diff)
downloadmaster-31e0f0ae-bc152ef2c51f23916fe442924b430ad441b9d886.tar.gz
master-31e0f0ae-bc152ef2c51f23916fe442924b430ad441b9d886.tar.bz2
master-31e0f0ae-bc152ef2c51f23916fe442924b430ad441b9d886.zip
squashfs4: add lzma support (kernel support still missing)
SVN-Revision: 15884
Diffstat (limited to 'tools/squashfs4/Makefile')
-rw-r--r--tools/squashfs4/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/tools/squashfs4/Makefile b/tools/squashfs4/Makefile
index f172d3bc6b..ddbca11403 100644
--- a/tools/squashfs4/Makefile
+++ b/tools/squashfs4/Makefile
@@ -20,6 +20,9 @@ include $(INCLUDE_DIR)/host-build.mk
define Host/Compile
$(MAKE) -C $(HOST_BUILD_DIR)/squashfs-tools \
+ USE_LZMA=1 \
+ LZMA_CFLAGS="-I$(STAGING_DIR_HOST)/include -DUSE_LZMA" \
+ LZMA_LIB="$(STAGING_DIR_HOST)/lib/liblzma.a" \
mksquashfs unsquashfs
endef