summaryrefslogtreecommitdiffstats
path: root/tools/ppl/patches
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-12-15 21:07:34 +0000
committerLuka Perkov <luka@openwrt.org>2013-12-15 21:07:34 +0000
commit5efbcf2f92ea542e0d829c4530e7d3602376756a (patch)
tree00ee09ea8e0dceee188f2ac1d15350282920bfd4 /tools/ppl/patches
parent152f0b70177c529a2d1ff179b0dbd289e071a532 (diff)
downloadmaster-31e0f0ae-5efbcf2f92ea542e0d829c4530e7d3602376756a.tar.gz
master-31e0f0ae-5efbcf2f92ea542e0d829c4530e7d3602376756a.tar.bz2
master-31e0f0ae-5efbcf2f92ea542e0d829c4530e7d3602376756a.zip
ppl: update to 1.1
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 39068
Diffstat (limited to 'tools/ppl/patches')
-rw-r--r--tools/ppl/patches/001-disable-serial-tests.patch44
-rw-r--r--tools/ppl/patches/001-gmp-conflicts.patch41
2 files changed, 44 insertions, 41 deletions
diff --git a/tools/ppl/patches/001-disable-serial-tests.patch b/tools/ppl/patches/001-disable-serial-tests.patch
new file mode 100644
index 0000000000..91b0753feb
--- /dev/null
+++ b/tools/ppl/patches/001-disable-serial-tests.patch
@@ -0,0 +1,44 @@
+--- a/tests/BD_Shape/Makefile.am
++++ b/tests/BD_Shape/Makefile.am
+@@ -21,8 +21,6 @@
+ # For the most up-to-date information see the Parma Polyhedra Library
+ # site: http://bugseng.com/products/ppl/ .
+
+-AUTOMAKE_OPTIONS = serial-tests
+-
+ if VALGRIND_TESTS_ENABLED
+
+ CHECKER = \
+--- a/tests/Box/Makefile.am
++++ b/tests/Box/Makefile.am
+@@ -21,8 +21,6 @@
+ # For the most up-to-date information see the Parma Polyhedra Library
+ # site: http://bugseng.com/products/ppl/ .
+
+-AUTOMAKE_OPTIONS = serial-tests
+-
+ if VALGRIND_TESTS_ENABLED
+
+ CHECKER = \
+--- a/tests/Concrete_Expression/Makefile.am
++++ b/tests/Concrete_Expression/Makefile.am
+@@ -21,8 +21,6 @@
+ # For the most up-to-date information see the Parma Polyhedra Library
+ # site: http://bugseng.com/products/ppl/ .
+
+-AUTOMAKE_OPTIONS = serial-tests
+-
+ if VALGRIND_TESTS_ENABLED
+
+ CHECKER = \
+--- a/tests/Octagonal_Shape/Makefile.am
++++ b/tests/Octagonal_Shape/Makefile.am
+@@ -21,8 +21,6 @@
+ # For the most up-to-date information see the Parma Polyhedra Library
+ # site: http://bugseng.com/products/ppl/ .
+
+-AUTOMAKE_OPTIONS = serial-tests
+-
+ if VALGRIND_TESTS_ENABLED
+
+ CHECKER = \
diff --git a/tools/ppl/patches/001-gmp-conflicts.patch b/tools/ppl/patches/001-gmp-conflicts.patch
deleted file mode 100644
index cf65ee5245..0000000000
--- a/tools/ppl/patches/001-gmp-conflicts.patch
+++ /dev/null
@@ -1,41 +0,0 @@
---- a/src/mp_std_bits.cc
-+++ b/src/mp_std_bits.cc
-@@ -25,6 +25,9 @@ site: http://bugseng.com/products/ppl/ . */
- #include "ppl-config.h"
- #include "mp_std_bits_defs.hh"
-
-+#if __GNU_MP_VERSION < 5 \
-+ || (__GNU_MP_VERSION == 5 && __GNU_MP_VERSION_MINOR < 1)
-+
- const bool std::numeric_limits<mpz_class>::is_specialized;
- const int std::numeric_limits<mpz_class>::digits;
- const int std::numeric_limits<mpz_class>::digits10;
-@@ -70,3 +73,6 @@ const bool std::numeric_limits<mpq_class>::is_modulo;
- const bool std::numeric_limits<mpq_class>::traps;
- const bool std::numeric_limits<mpq_class>::tininess_before;
- const std::float_round_style std::numeric_limits<mpq_class>::round_style;
-+
-+#endif // __GNU_MP_VERSION < 5
-+ // || (__GNU_MP_VERSION == 5 && __GNU_MP_VERSION_MINOR < 1)
---- a/src/mp_std_bits.defs.hh
-+++ b/src/mp_std_bits.defs.hh
-@@ -38,6 +38,9 @@
- #endif // defined(PPL_DOXYGEN_INCLUDE_IMPLEMENTATION_DETAILS)
- void swap(mpq_class& x, mpq_class& y);
-
-+#if __GNU_MP_VERSION < 5 \
-+ || (__GNU_MP_VERSION == 5 && __GNU_MP_VERSION_MINOR < 1)
-+
- namespace std {
-
- #ifdef PPL_DOXYGEN_INCLUDE_IMPLEMENTATION_DETAILS
-@@ -164,6 +167,9 @@
-
- } // namespace std
-
-+#endif // __GNU_MP_VERSION < 5
-+ // || (__GNU_MP_VERSION == 5 && __GNU_MP_VERSION_MINOR < 1)
-+
- #include "mp_std_bits.inlines.hh"
-
- #endif // !defined(PPL_mp_std_bits_defs_hh)