summaryrefslogtreecommitdiffstats
path: root/tools/ppl/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-08-14 23:23:23 +0000
committerLuka Perkov <luka@openwrt.org>2013-08-14 23:23:23 +0000
commit884ae691890b43f84f8c6fc283737bc5c807fd0d (patch)
treee5ab221b657290507593d5688d620f4c279d3607 /tools/ppl/Makefile
parentdc7164d4efd172fb412d24849dc477992251e4b7 (diff)
downloadmaster-31e0f0ae-884ae691890b43f84f8c6fc283737bc5c807fd0d.tar.gz
master-31e0f0ae-884ae691890b43f84f8c6fc283737bc5c807fd0d.tar.bz2
master-31e0f0ae-884ae691890b43f84f8c6fc283737bc5c807fd0d.zip
ppl: upgrade to 1.0
Signed-off-by: Luka Perkov <lperkov@cisco.com> SVN-Revision: 37786
Diffstat (limited to 'tools/ppl/Makefile')
-rw-r--r--tools/ppl/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/tools/ppl/Makefile b/tools/ppl/Makefile
index 46c966d827..2f54c30c7d 100644
--- a/tools/ppl/Makefile
+++ b/tools/ppl/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -7,14 +7,17 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ppl
-PKG_VERSION:=0.10.2
+PKG_VERSION:=1.0
-PKG_SOURCE_URL:=ftp://gcc.gnu.org/pub/gcc/infrastructure
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=e7dd265afdeaea81f7e87a72b182d875
+PKG_SOURCE_URL:=http://bugseng.com/products/ppl/download/ftp/releases/1.0/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_MD5SUM:=e8caeb84cd858f64b36333c368891c7b
HOST_FIXUP:=autoreconf
+HOST_BUILD_PARALLEL:=1
+HOST_CONFIGURE_PARALLEL:=1
+
include $(INCLUDE_DIR)/host-build.mk
unexport CFLAGS
@@ -31,5 +34,4 @@ define Host/Configure
)
endef
-
$(eval $(call HostBuild))