summaryrefslogtreecommitdiffstats
path: root/tools/pkg-config
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-06 00:00:43 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-06 00:00:43 +0000
commitf7e56763e12bdff2261929bbcb691e770341d043 (patch)
treecb0044ff6c628138051f7aedd18077393b5d5ed6 /tools/pkg-config
parent5f65074523fa53a2599a868269a20f5971bc7797 (diff)
downloadmaster-31e0f0ae-f7e56763e12bdff2261929bbcb691e770341d043.tar.gz
master-31e0f0ae-f7e56763e12bdff2261929bbcb691e770341d043.tar.bz2
master-31e0f0ae-f7e56763e12bdff2261929bbcb691e770341d043.zip
tools: remove static linking support
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 44285
Diffstat (limited to 'tools/pkg-config')
-rw-r--r--tools/pkg-config/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/tools/pkg-config/Makefile b/tools/pkg-config/Makefile
index 0edc807e9d..9a1b3fb986 100644
--- a/tools/pkg-config/Makefile
+++ b/tools/pkg-config/Makefile
@@ -17,14 +17,12 @@ HOST_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/host-build.mk
-HOST_LDFLAGS += $(HOST_STATIC_LINKING)
unexport PKG_CONFIG
HOST_CONFIGURE_ARGS += --with-internal-glib
define Host/Install
- $(MAKE) -C $(HOST_BUILD_DIR) install \
- AM_LDFLAGS="$(if $(HOST_STATIC_LINKING),-all-static)"
+ $(MAKE) -C $(HOST_BUILD_DIR) install
mv $(STAGING_DIR_HOST)/bin/pkg-config $(STAGING_DIR_HOST)/bin/pkg-config.real
$(INSTALL_BIN) ./files/pkg-config $(STAGING_DIR_HOST)/bin/pkg-config
endef