summaryrefslogtreecommitdiffstats
path: root/tools/pkg-config
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-08-12 12:34:30 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-08-12 12:34:30 +0000
commitcf1698c6370d6a64f5f70a2dc5652d1fbc62afc3 (patch)
tree8dea115df7f768723281ea58c0ce7d0c4180182b /tools/pkg-config
parent095fe8743b64a47ea2b13642934348f914d2a2bb (diff)
downloadmaster-31e0f0ae-cf1698c6370d6a64f5f70a2dc5652d1fbc62afc3.tar.gz
master-31e0f0ae-cf1698c6370d6a64f5f70a2dc5652d1fbc62afc3.tar.bz2
master-31e0f0ae-cf1698c6370d6a64f5f70a2dc5652d1fbc62afc3.zip
use HOST_STATIC_LINKING instead of hardcoding -static
SVN-Revision: 33140
Diffstat (limited to 'tools/pkg-config')
-rw-r--r--tools/pkg-config/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/tools/pkg-config/Makefile b/tools/pkg-config/Makefile
index fbdc1d0db7..01bfdb0d68 100644
--- a/tools/pkg-config/Makefile
+++ b/tools/pkg-config/Makefile
@@ -15,10 +15,11 @@ PKG_MD5SUM:=a3270bab3f4b69b7dc6dbdacbcae9745
include $(INCLUDE_DIR)/host-build.mk
-HOST_LDFLAGS += -static
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
define Host/Install
- $(MAKE) -C $(HOST_BUILD_DIR) install AM_LDFLAGS="-all-static"
+ $(MAKE) -C $(HOST_BUILD_DIR) install \
+ AM_LDFLAGS="$(if $(HOST_STATIC_LINKING),-all-static)"
mv $(STAGING_DIR_HOST)/bin/pkg-config $(STAGING_DIR_HOST)/bin/pkg-config.real
$(INSTALL_BIN) ./files/pkg-config $(STAGING_DIR_HOST)/bin/pkg-config
endef