summaryrefslogtreecommitdiffstats
path: root/tools/pkg-config
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2007-10-06 23:50:47 +0000
committerJohn Crispin <john@openwrt.org>2007-10-06 23:50:47 +0000
commitc3847b8e5d32bd6775d5202eb154d07d8b54989c (patch)
treef69bddfdbadfc5a398768977e14fe528efd799b1 /tools/pkg-config
parent446881738fd02c91e0489178f5ee8e39218e682b (diff)
downloadmaster-31e0f0ae-c3847b8e5d32bd6775d5202eb154d07d8b54989c.tar.gz
master-31e0f0ae-c3847b8e5d32bd6775d5202eb154d07d8b54989c.tar.bz2
master-31e0f0ae-c3847b8e5d32bd6775d5202eb154d07d8b54989c.zip
added our own pkg-config wrapper, making the sed foo on *.pc files obselete 1/2
SVN-Revision: 9162
Diffstat (limited to 'tools/pkg-config')
-rw-r--r--tools/pkg-config/Makefile35
-rwxr-xr-xtools/pkg-config/files/pkg-config3
2 files changed, 38 insertions, 0 deletions
diff --git a/tools/pkg-config/Makefile b/tools/pkg-config/Makefile
new file mode 100644
index 0000000000..bcae2dfa69
--- /dev/null
+++ b/tools/pkg-config/Makefile
@@ -0,0 +1,35 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pkg-config
+PKG_VERSION:=0.22
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://pkgconfig.freedesktop.org/releases/
+PKG_MD5SUM:=fd5c547e9d66ba49bc735ccb8c791f2a
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR)
+endef
+
+define Build/Install
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ install
+ mv $(STAGING_DIR_HOST)/bin/pkg-config $(STAGING_DIR_HOST)/bin/pkg-config.real
+ $(INSTALL_BIN) ./files/pkg-config $(STAGING_DIR_HOST)/bin/pkg-config
+endef
+
+define Build/Clean
+ $(MAKE) -C $(PKG_BUILD_DIR) uninstall
+ $(MAKE) -C $(PKG_BUILD_DIR) clean
+ $(call Build/Clean/Default)
+endef
+
+$(eval $(call HostBuild))
diff --git a/tools/pkg-config/files/pkg-config b/tools/pkg-config/files/pkg-config
new file mode 100755
index 0000000000..31cfd0d83d
--- /dev/null
+++ b/tools/pkg-config/files/pkg-config
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+pkg-config.real $@ --define-variable=libdir=${STAGING_DIR}/usr/lib --define-variable=includedir=${STAGING_DIR}/usr/include