summaryrefslogtreecommitdiffstats
path: root/tools/pkg-config
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-10-28 15:15:12 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-10-28 15:15:12 +0000
commit8fb4f34859150fdf1432ede4fb8c5b4a653dd362 (patch)
tree625c0e4ae8c8038e0e35f2dcad554b43d5b9ceb6 /tools/pkg-config
parent1879c5f8e74d14d23a5b440dd4bf85f6f5b7e908 (diff)
downloadmaster-31e0f0ae-8fb4f34859150fdf1432ede4fb8c5b4a653dd362.tar.gz
master-31e0f0ae-8fb4f34859150fdf1432ede4fb8c5b4a653dd362.tar.bz2
master-31e0f0ae-8fb4f34859150fdf1432ede4fb8c5b4a653dd362.zip
pkg-config: update to latest version, fix build on Mac OS X 10.9
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 38561
Diffstat (limited to 'tools/pkg-config')
-rw-r--r--tools/pkg-config/Makefile7
-rw-r--r--tools/pkg-config/patches/100-disable_compat_cmd.patch22
2 files changed, 5 insertions, 24 deletions
diff --git a/tools/pkg-config/Makefile b/tools/pkg-config/Makefile
index b72f3ce457..6bd53f8610 100644
--- a/tools/pkg-config/Makefile
+++ b/tools/pkg-config/Makefile
@@ -7,17 +7,20 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=pkg-config
-PKG_VERSION:=0.25
+PKG_VERSION:=0.28
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://pkgconfig.freedesktop.org/releases/
-PKG_MD5SUM:=a3270bab3f4b69b7dc6dbdacbcae9745
+PKG_MD5SUM:=aa3c86e67551adc3ac865160e34a2a0d
HOST_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/host-build.mk
HOST_LDFLAGS += $(HOST_STATIC_LINKING)
+unexport PKG_CONFIG
+
+HOST_CONFIGURE_ARGS += --with-internal-glib
define Host/Install
$(MAKE) -C $(HOST_BUILD_DIR) install \
diff --git a/tools/pkg-config/patches/100-disable_compat_cmd.patch b/tools/pkg-config/patches/100-disable_compat_cmd.patch
deleted file mode 100644
index 990784045e..0000000000
--- a/tools/pkg-config/patches/100-disable_compat_cmd.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/parse.c
-+++ b/parse.c
-@@ -1187,15 +1187,12 @@ try_command (const char *command)
- Package *
- get_compat_package (const char *name)
- {
--#ifdef G_OS_WIN32
-- /* There has never been any of these legacy *-config scripts on
-- * Windows as far as I know. No use trying to execute them, will
-- * only confuse users to see the "blabla is not recognized as an
-- * internal or external command, operable program or batch file"
-- * messages.
-+ /*
-+ * We don't need this compatibility stuff on a system
-+ * that is free of legacy stuff
- */
- return NULL;
--#else
-+#if 0
-
- Package *pkg;
-