summaryrefslogtreecommitdiffstats
path: root/tools/patch-image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-11-02 20:06:45 +0000
committerJohn Crispin <john@openwrt.org>2012-11-02 20:06:45 +0000
commit1a7334a87431ec1e20d4082a36043342713fd941 (patch)
tree84074305802cb18ffd5df86b980ceb467fc24db3 /tools/patch-image/Makefile
parent00057626901725d0b64045f6823d67edae691e00 (diff)
downloadmaster-31e0f0ae-1a7334a87431ec1e20d4082a36043342713fd941.tar.gz
master-31e0f0ae-1a7334a87431ec1e20d4082a36043342713fd941.tar.bz2
master-31e0f0ae-1a7334a87431ec1e20d4082a36043342713fd941.zip
rename patch-cmdline and add code for patching DTB files into kernel images
SVN-Revision: 34058
Diffstat (limited to 'tools/patch-image/Makefile')
-rw-r--r--tools/patch-image/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/tools/patch-image/Makefile b/tools/patch-image/Makefile
new file mode 100644
index 0000000000..cd2df5c8af
--- /dev/null
+++ b/tools/patch-image/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2007-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=patch-image
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Compile
+ $(HOSTCC) $(HOST_CFLAGS) -include endian.h $(HOST_STATIC_LINKING) -o $(HOST_BUILD_DIR)/patch-cmdline src/patch-cmdline.c
+ $(HOSTCC) $(HOST_CFLAGS) -include endian.h $(HOST_STATIC_LINKING) -o $(HOST_BUILD_DIR)/patch-dtb src/patch-dtb.c
+endef
+
+define Host/Install
+ $(CP) $(HOST_BUILD_DIR)/patch-cmdline $(STAGING_DIR_HOST)/bin/
+ $(CP) $(HOST_BUILD_DIR)/patch-dtb $(STAGING_DIR_HOST)/bin/
+endef
+
+define Host/Clean
+ rm -f $(STAGING_DIR_HOST)/bin/patch-cmdline
+ rm -f $(STAGING_DIR_HOST)/bin/patch-dtb
+endef
+
+$(eval $(call HostBuild))