summaryrefslogtreecommitdiffstats
path: root/tools/mpfr
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-06 09:56:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-06 09:56:25 +0000
commit9493f9c19ed2c7d407dcd70e72934c00e3b5849a (patch)
tree11b0377f6d8a13490bc872f866f4ee36df1f67ae /tools/mpfr
parent17b4ce5bc2c7bb9169d1044c18d585bf577a1e57 (diff)
downloadmaster-31e0f0ae-9493f9c19ed2c7d407dcd70e72934c00e3b5849a.tar.gz
master-31e0f0ae-9493f9c19ed2c7d407dcd70e72934c00e3b5849a.tar.bz2
master-31e0f0ae-9493f9c19ed2c7d407dcd70e72934c00e3b5849a.zip
clean up gmp and mpfr
SVN-Revision: 15114
Diffstat (limited to 'tools/mpfr')
-rw-r--r--tools/mpfr/Makefile26
1 files changed, 4 insertions, 22 deletions
diff --git a/tools/mpfr/Makefile b/tools/mpfr/Makefile
index 5abb2a2c79..17734a246a 100644
--- a/tools/mpfr/Makefile
+++ b/tools/mpfr/Makefile
@@ -15,27 +15,9 @@ PKG_MD5SUM:=527147c097874340cb9cee0579dacf3b
include $(INCLUDE_DIR)/host-build.mk
-define Host/Configure
- (cd $(HOST_BUILD_DIR); \
- ./configure \
- --prefix=$(STAGING_DIR_HOST) \
- --build=$(GNU_HOST_NAME) \
- --enable-static \
- --disable-shared \
- --with-gmp=$(STAGING_DIR_HOST) \
- );
-endef
-
-define Host/Compile
- make -C $(HOST_BUILD_DIR) all
-endef
-
-define Host/Install
- make -C $(HOST_BUILD_DIR) install
-endef
-
-define Host/Clean
- rm -rf $(HOST_BUILD_DIR)
-endef
+HOST_CONFIGURE_ARGS += \
+ --enable-static \
+ --disable-shared \
+ --with-gmp=$(STAGING_DIR_HOST)
$(eval $(call HostBuild))