summaryrefslogtreecommitdiffstats
path: root/tools/mm-macros
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-12-22 00:03:15 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-12-22 00:03:15 +0000
commit6ed509a8a7151a50a87877218516bd47c28c8652 (patch)
tree80b5a7874d03d0966e721dac92fa25e3fd597cc2 /tools/mm-macros
parent214d1e7aeb2f1016126bfbc9abcb06b1c8f057db (diff)
downloadmaster-31e0f0ae-6ed509a8a7151a50a87877218516bd47c28c8652.tar.gz
master-31e0f0ae-6ed509a8a7151a50a87877218516bd47c28c8652.tar.bz2
master-31e0f0ae-6ed509a8a7151a50a87877218516bd47c28c8652.zip
add missing makefile in previous commit
SVN-Revision: 24755
Diffstat (limited to 'tools/mm-macros')
-rw-r--r--tools/mm-macros/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/tools/mm-macros/Makefile b/tools/mm-macros/Makefile
new file mode 100644
index 0000000000..60dcde6328
--- /dev/null
+++ b/tools/mm-macros/Makefile
@@ -0,0 +1,31 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mm-macros
+PKG_VERSION:=0.9.2
+
+PKG_SOURCE_URL:=http://ftp.gnome.org/pub/GNOME/sources/mm-common/0.9
+PKG_SOURCE:=mm-common-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=8cdc5620bd864d1a17e353398e8ec1ab
+
+HOST_BUILD_DIR:=$(BUILD_DIR)/mm-common-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Install
+ $(INSTALL_DIR) $(STAGING_DIR_HOST)/share/aclocal
+ $(INSTALL_DATA) $(HOST_BUILD_DIR)/macros/*.m4 $(STAGING_DIR_HOST)/share/aclocal/
+endef
+
+define Host/Clean
+ -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))