summaryrefslogtreecommitdiffstats
path: root/tools/mklibs
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-08-08 02:24:54 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-08-08 02:24:54 +0000
commita6a83985a02abf67ca0164285ce860a512fa5eab (patch)
treea08ea70bd3440bd6b4a284728c8840a5521665ee /tools/mklibs
parent583f6f2d6a7ec316bb18e642cddeeb17f194d058 (diff)
downloadmaster-31e0f0ae-a6a83985a02abf67ca0164285ce860a512fa5eab.tar.gz
master-31e0f0ae-a6a83985a02abf67ca0164285ce860a512fa5eab.tar.bz2
master-31e0f0ae-a6a83985a02abf67ca0164285ce860a512fa5eab.zip
upgrade mklibs to 0.1.29 - fixes runtime errors in mklibs-readelf
SVN-Revision: 17171
Diffstat (limited to 'tools/mklibs')
-rw-r--r--tools/mklibs/Makefile6
-rw-r--r--tools/mklibs/patches/001-missing_stdio.patch7
-rw-r--r--tools/mklibs/patches/002-disable_symbol_checks.patch6
3 files changed, 10 insertions, 9 deletions
diff --git a/tools/mklibs/Makefile b/tools/mklibs/Makefile
index 50532244e6..bd967217ea 100644
--- a/tools/mklibs/Makefile
+++ b/tools/mklibs/Makefile
@@ -7,11 +7,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mklibs
-PKG_VERSION:=0.1.26
+PKG_VERSION:=0.1.29
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/m/mklibs/
-PKG_MD5SUM:=708f284975f1b567b817d27f7677a95f
+PKG_MD5SUM:=7f35dfdbde249a090199829c1a1222d8
+
+HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/mklibs
include $(INCLUDE_DIR)/host-build.mk
diff --git a/tools/mklibs/patches/001-missing_stdio.patch b/tools/mklibs/patches/001-missing_stdio.patch
index c8202fb1e1..fe05ee29a8 100644
--- a/tools/mklibs/patches/001-missing_stdio.patch
+++ b/tools/mklibs/patches/001-missing_stdio.patch
@@ -1,7 +1,6 @@
-diff -urN mklibs-0.1.26/src/mklibs-readelf/main.cpp mklibs-0.1.26.new/src/mklibs-readelf/main.cpp
---- mklibs-0.1.26/src/mklibs-readelf/main.cpp 2007-09-20 19:41:34.000000000 +0200
-+++ mklibs-0.1.26.new/src/mklibs-readelf/main.cpp 2009-08-07 12:20:21.000000000 +0200
-@@ -6,6 +6,7 @@
+--- a/src/mklibs-readelf/main.cpp
++++ b/src/mklibs-readelf/main.cpp
+@@ -7,6 +7,7 @@
#include <elf.h>
#include <getopt.h>
diff --git a/tools/mklibs/patches/002-disable_symbol_checks.patch b/tools/mklibs/patches/002-disable_symbol_checks.patch
index 0100742518..7ec63937c4 100644
--- a/tools/mklibs/patches/002-disable_symbol_checks.patch
+++ b/tools/mklibs/patches/002-disable_symbol_checks.patch
@@ -1,6 +1,6 @@
--- a/src/mklibs.py
+++ b/src/mklibs.py
-@@ -429,7 +429,7 @@ while 1:
+@@ -500,7 +500,7 @@ while 1:
# No progress in last pass. Verify all remaining symbols are weak.
for name in unresolved:
if not needed_symbols[name].weak:
@@ -9,13 +9,13 @@
break
previous_pass_unresolved = unresolved
-@@ -467,10 +467,7 @@ while 1:
+@@ -533,10 +533,7 @@ while 1:
# which symbols are actually used from each lib
for name in needed_symbols:
- if not name in symbol_provider:
- if not needed_symbols[name].weak:
-- raise "No library provides non-weak %s" % symbol
+- raise "No library provides non-weak %s" % name
- else:
+ if name in symbol_provider:
lib = symbol_provider[name]