summaryrefslogtreecommitdiffstats
path: root/tools/mklibs/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-08-07 00:07:18 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-08-07 00:07:18 +0000
commit36aa20bdab8284c503b5871288f2ffe1b0ea4074 (patch)
treed7cb0b10083ba506fd651e1e3a60e119703b2e72 /tools/mklibs/Makefile
parent5138aa203ee761847a56143eb3ab6136df36ae51 (diff)
downloadmaster-31e0f0ae-36aa20bdab8284c503b5871288f2ffe1b0ea4074.tar.gz
master-31e0f0ae-36aa20bdab8284c503b5871288f2ffe1b0ea4074.tar.bz2
master-31e0f0ae-36aa20bdab8284c503b5871288f2ffe1b0ea4074.zip
add mklibs (based on a patch by florian) in preparation for optional library symbol stripping
SVN-Revision: 17154
Diffstat (limited to 'tools/mklibs/Makefile')
-rw-r--r--tools/mklibs/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/tools/mklibs/Makefile b/tools/mklibs/Makefile
new file mode 100644
index 0000000000..50532244e6
--- /dev/null
+++ b/tools/mklibs/Makefile
@@ -0,0 +1,32 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mklibs
+PKG_VERSION:=0.1.26
+
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/m/mklibs/
+PKG_MD5SUM:=708f284975f1b567b817d27f7677a95f
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_CFLAGS += -I$(CURDIR)/include
+
+define Host/Install
+ $(INSTALL_BIN) \
+ $(HOST_BUILD_DIR)/src/mklibs.py \
+ $(HOST_BUILD_DIR)/src/mklibs-copy.py \
+ $(HOST_BUILD_DIR)/src/mklibs-readelf/mklibs-readelf \
+ $(STAGING_DIR_HOST)/bin/
+endef
+
+define Host/Clean
+ rm -f $(STAGING_DIR_HOST)/bin/mklibs*
+endef
+
+$(eval $(call HostBuild))