summaryrefslogtreecommitdiffstats
path: root/tools/mkimage/patches
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-09-23 08:49:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-09-23 08:49:34 +0000
commitdcd3a74da01df1c2660e8fc67762a06746bd52c3 (patch)
tree5cd9680dae14b36b61679530eefc1d64f47259d2 /tools/mkimage/patches
parentd406a5208f6ff28b70993b3e9ae32e3f895f0335 (diff)
downloadmaster-31e0f0ae-dcd3a74da01df1c2660e8fc67762a06746bd52c3.tar.gz
master-31e0f0ae-dcd3a74da01df1c2660e8fc67762a06746bd52c3.tar.bz2
master-31e0f0ae-dcd3a74da01df1c2660e8fc67762a06746bd52c3.zip
tools/mkimage: avoid picking up unrelated /usr/include headers with the same name as internal header files (e.g. image.h), fixes #12232
SVN-Revision: 33519
Diffstat (limited to 'tools/mkimage/patches')
-rw-r--r--tools/mkimage/patches/040-include_order.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/tools/mkimage/patches/040-include_order.patch b/tools/mkimage/patches/040-include_order.patch
new file mode 100644
index 0000000000..5a9d15eb76
--- /dev/null
+++ b/tools/mkimage/patches/040-include_order.patch
@@ -0,0 +1,14 @@
+--- a/tools/Makefile
++++ b/tools/Makefile
+@@ -159,9 +159,9 @@ NOPEDOBJS := $(addprefix $(obj),$(NOPED_
+ # Use native tools and options
+ # Define __KERNEL_STRICT_NAMES to prevent typedef overlaps
+ #
+-HOSTCPPFLAGS = -idirafter $(SRCTREE)/include \
++HOSTCPPFLAGS = -I $(SRCTREE)/include \
+ -idirafter $(OBJTREE)/include2 \
+- -idirafter $(OBJTREE)/include \
++ -I $(OBJTREE)/include \
+ -I $(SRCTREE)/lib/libfdt \
+ -I $(SRCTREE)/tools \
+ -DCONFIG_SYS_TEXT_BASE=$(CONFIG_SYS_TEXT_BASE) \