summaryrefslogtreecommitdiffstats
path: root/tools/mkimage/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-03-08 20:16:11 +0000
committerLuka Perkov <luka@openwrt.org>2013-03-08 20:16:11 +0000
commit9c8ee9c2642555637eb7f12a72c3aea1ad5e62d6 (patch)
tree0bca50f87ea85cd0d62346af73ce6345f3c25ac9 /tools/mkimage/Makefile
parente259ecad7ed76b0300b5ad3418b6895f1f45c59e (diff)
downloadmaster-31e0f0ae-9c8ee9c2642555637eb7f12a72c3aea1ad5e62d6.tar.gz
master-31e0f0ae-9c8ee9c2642555637eb7f12a72c3aea1ad5e62d6.tar.bz2
master-31e0f0ae-9c8ee9c2642555637eb7f12a72c3aea1ad5e62d6.zip
mkimage: upgrade to version 2013.01.01
SVN-Revision: 35905
Diffstat (limited to 'tools/mkimage/Makefile')
-rw-r--r--tools/mkimage/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/tools/mkimage/Makefile b/tools/mkimage/Makefile
index 149aaa6f12..7bd7316537 100644
--- a/tools/mkimage/Makefile
+++ b/tools/mkimage/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -7,11 +7,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mkimage
-PKG_VERSION:=2012.04.01
+PKG_VERSION:=2013.01.01
PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=192bb231082d9159fb6e16de3039b6b2
+PKG_MD5SUM:=73939f78606f89a1775c7e9acb2ca617
PKG_CAT:=bzcat
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
@@ -22,12 +22,12 @@ define Host/Prepare
$(Host/Prepare/Default)
rm -f \
$(HOST_BUILD_DIR)/include/errno.h \
- $(HOST_BUILD_DIR)/include/malloc.h
+ $(HOST_BUILD_DIR)/include/malloc.h \
+ $(HOST_BUILD_DIR)/tools/.depend
+ touch $(HOST_BUILD_DIR)/include/config.h
endef
define Host/Compile
- rm -f $(HOST_BUILD_DIR)/tools/.depend
- touch $(HOST_BUILD_DIR)/include/config.h
$(MAKE) -C $(HOST_BUILD_DIR) BUILD_DIR= BIN_FILES-y="mkimage" HOSTLDFLAGS="$(HOST_STATIC_LINKING)" tools
endef