summaryrefslogtreecommitdiffstats
path: root/tools/mkimage/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-13 22:51:49 +0200
committerFelix Fietkau <nbd@openwrt.org>2016-03-20 17:29:15 +0100
commit60c1f0f64d23003a19a07d6b9638542130f6641d (patch)
tree8fb2787f4c49baded97cd55e0c371fe1cffce2b6 /tools/mkimage/Makefile
parentd58a09110ccfa95f06c983fe796806f2e035c9d2 (diff)
parentb3ce218b51746d3a576221ea542facf3a1703ab2 (diff)
downloadmaster-31e0f0ae-60c1f0f64d23003a19a07d6b9638542130f6641d.tar.gz
master-31e0f0ae-60c1f0f64d23003a19a07d6b9638542130f6641d.tar.bz2
master-31e0f0ae-60c1f0f64d23003a19a07d6b9638542130f6641d.zip
finally move buildroot-ng to trunk
Diffstat (limited to 'tools/mkimage/Makefile')
-rw-r--r--tools/mkimage/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/tools/mkimage/Makefile b/tools/mkimage/Makefile
new file mode 100644
index 0000000000..71285d2e1a
--- /dev/null
+++ b/tools/mkimage/Makefile
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/host-build.mk
+
+PKG_BUILD_DIR:=$(TOOL_BUILD_DIR)/mkimage
+
+define Build/Compile
+ $(CC) -O -c src/crc32.c -o $(PKG_BUILD_DIR)/crc32.o
+ $(CC) -O -c src/mkimage.c -o $(PKG_BUILD_DIR)/mkimage.o
+ $(CC) -O -o $(PKG_BUILD_DIR)/mkimage $(PKG_BUILD_DIR)/mkimage.o $(PKG_BUILD_DIR)/crc32.o
+endef
+
+define Build/Install
+ mkdir -p $(STAGING_DIR)/bin
+ $(CP) $(PKG_BUILD_DIR)/mkimage $(STAGING_DIR)/bin/
+endef
+
+define Build/Clean
+ rm -f $(STAGING_DIR)/bin/mkimage
+endef
+
+$(eval $(call HostBuild))