summaryrefslogtreecommitdiffstats
path: root/tools/mkimage/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-11-29 22:43:59 +0000
committerLuka Perkov <luka@openwrt.org>2014-11-29 22:43:59 +0000
commit25d8cb275e1f16bb80c6d05dcf6d73d8d6882053 (patch)
tree7f6d41071498538edf4f3927515e4d84e65f66eb /tools/mkimage/Makefile
parent070d3b27c223f23a4793667264441f8c2f008755 (diff)
downloadmaster-31e0f0ae-25d8cb275e1f16bb80c6d05dcf6d73d8d6882053.tar.gz
master-31e0f0ae-25d8cb275e1f16bb80c6d05dcf6d73d8d6882053.tar.bz2
master-31e0f0ae-25d8cb275e1f16bb80c6d05dcf6d73d8d6882053.zip
mkimage: update to 2014.10
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 43428
Diffstat (limited to 'tools/mkimage/Makefile')
-rw-r--r--tools/mkimage/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/tools/mkimage/Makefile b/tools/mkimage/Makefile
index 49eb26184d..2de13ab77b 100644
--- a/tools/mkimage/Makefile
+++ b/tools/mkimage/Makefile
@@ -7,11 +7,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mkimage
-PKG_VERSION:=2014.07
+PKG_VERSION:=2014.10
PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=36d4bad687edcafa396fee607e505d4e
+PKG_SOURCE_URL:=\
+ http://mirror2.openwrt.org/sources \
+ ftp://ftp.denx.de/pub/u-boot
+PKG_MD5SUM:=3ddcaee2f05b7c464778112ec83664b5
PKG_CAT:=bzcat
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
@@ -29,6 +31,7 @@ define Host/Prepare
endef
define Host/Compile
+ $(MAKE) -C $(HOST_BUILD_DIR) defconfig
$(MAKE) -C $(HOST_BUILD_DIR) \
HOSTLDFLAGS="$(HOST_STATIC_LINKING)" \
tools-only