summaryrefslogtreecommitdiffstats
path: root/tools/missing-macros/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-12-21 23:50:41 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-12-21 23:50:41 +0000
commite3269cc34e516859cd536f1fe3f2180fd350267c (patch)
tree00cc13b831e8382a6541f3876f9814afa74c6c6b /tools/missing-macros/Makefile
parentc4ab5ca14370406cdccaff868b2e655a2f21aa72 (diff)
downloadmaster-31e0f0ae-e3269cc34e516859cd536f1fe3f2180fd350267c.tar.gz
master-31e0f0ae-e3269cc34e516859cd536f1fe3f2180fd350267c.tar.bz2
master-31e0f0ae-e3269cc34e516859cd536f1fe3f2180fd350267c.zip
introduce missing-macros meta package, this will supply needed m4 macros which are used but not shipped by various packages in feeds
SVN-Revision: 24753
Diffstat (limited to 'tools/missing-macros/Makefile')
-rw-r--r--tools/missing-macros/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/tools/missing-macros/Makefile b/tools/missing-macros/Makefile
new file mode 100644
index 0000000000..779dbfa7f3
--- /dev/null
+++ b/tools/missing-macros/Makefile
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=missing-macros
+PKG_VERSION:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Configure
+endef
+
+define Host/Compile
+endef
+
+define Host/Install
+ $(INSTALL_DIR) $(STAGING_DIR_HOST)/share/aclocal
+ $(INSTALL_DATA) ./src/m4/*.m4 $(STAGING_DIR_HOST)/share/aclocal/
+endef
+
+$(eval $(call HostBuild))