summaryrefslogtreecommitdiffstats
path: root/tools/make-ext4fs
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-04-20 13:57:43 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-04-20 13:57:43 +0000
commit0ee950491197e8c528249d64ca3276b39bad0ddd (patch)
treed114f48ebb450250489833cdd8c4bf2ac61e5d9b /tools/make-ext4fs
parent3edc273a332b08773068e0e1c974ad40fe58b9b9 (diff)
downloadmaster-31e0f0ae-0ee950491197e8c528249d64ca3276b39bad0ddd.tar.gz
master-31e0f0ae-0ee950491197e8c528249d64ca3276b39bad0ddd.tar.bz2
master-31e0f0ae-0ee950491197e8c528249d64ca3276b39bad0ddd.zip
all: replace genext2fs with make_ext4fs
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 45517
Diffstat (limited to 'tools/make-ext4fs')
-rw-r--r--tools/make-ext4fs/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/tools/make-ext4fs/Makefile b/tools/make-ext4fs/Makefile
new file mode 100644
index 0000000000..5149ed4a14
--- /dev/null
+++ b/tools/make-ext4fs/Makefile
@@ -0,0 +1,36 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=make-ext4fs
+PKG_VERSION:=2015-04-08
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://git.openwrt.org/project/make_ext4fs.git
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_VERSION:=2f713da924fa20cf89c25f2d122b54b959b09f87
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_MIRROR_MD5SUM:=c88f4f7c76e3142fc5ef12a723d9ef9b
+PKG_CAT:=zcat
+
+HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Compile
+ $(MAKE) -C $(HOST_BUILD_DIR) make_ext4fs
+endef
+
+define Host/Install
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/make_ext4fs $(STAGING_DIR_HOST)/bin/
+endef
+
+define Host/Clean
+ rm -f $(STAGING_DIR_HOST)/bin/make_ext4fs
+endef
+
+$(eval $(call HostBuild))