summaryrefslogtreecommitdiffstats
path: root/tools/lzma/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-05-17 00:57:47 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-05-17 00:57:47 +0000
commit9da8f2b2a0bfe1e39ab469769a7af9834fb706eb (patch)
tree5460808f59f540f4708fb4096a2641b2f20260b3 /tools/lzma/Makefile
parentc1a929efbd997e6b88a9db317cf513dc9fd59497 (diff)
downloadmaster-31e0f0ae-9da8f2b2a0bfe1e39ab469769a7af9834fb706eb.tar.gz
master-31e0f0ae-9da8f2b2a0bfe1e39ab469769a7af9834fb706eb.tar.bz2
master-31e0f0ae-9da8f2b2a0bfe1e39ab469769a7af9834fb706eb.zip
add the new lzma library (version 4.65), to be used for squashfs4
SVN-Revision: 15883
Diffstat (limited to 'tools/lzma/Makefile')
-rw-r--r--tools/lzma/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/tools/lzma/Makefile b/tools/lzma/Makefile
new file mode 100644
index 0000000000..18fe030886
--- /dev/null
+++ b/tools/lzma/Makefile
@@ -0,0 +1,35 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lzma
+PKG_VERSION:=4.65
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
+PKG_MD5SUM:=434e51a018b4c8ef377bf81520a53af0
+
+HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/host-build.mk
+
+UTIL_DIR=$(HOST_BUILD_DIR)/C/LzmaUtil
+
+define Host/Compile
+ $(MAKE) -C $(UTIL_DIR) -f makefile.gcc
+endef
+
+define Host/Install
+ $(INSTALL_DIR) $(STAGING_DIR_HOST)/lib $(STAGING_DIR_HOST)/include
+ $(CP) $(HOST_BUILD_DIR)/C/*.h $(STAGING_DIR_HOST)/include/
+ $(CP) $(UTIL_DIR)/liblzma.a $(STAGING_DIR_HOST)/lib/
+endef
+
+define Host/Clean
+endef
+
+$(eval $(call HostBuild))