summaryrefslogtreecommitdiffstats
path: root/tools/isl
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-13 11:35:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-13 11:35:37 +0000
commit3d41dbae65fb3d5103dd0a7d6178c4990596b3db (patch)
treebd2aa67d88efe69998d385a796a1d723d04e6609 /tools/isl
parentedd87061ec872ea539e95bcea71c80e2fc5bc3d4 (diff)
downloadmaster-31e0f0ae-3d41dbae65fb3d5103dd0a7d6178c4990596b3db.tar.gz
master-31e0f0ae-3d41dbae65fb3d5103dd0a7d6178c4990596b3db.tar.bz2
master-31e0f0ae-3d41dbae65fb3d5103dd0a7d6178c4990596b3db.zip
tools: add isl (used for graphite on GCC 5)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 47464
Diffstat (limited to 'tools/isl')
-rw-r--r--tools/isl/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/tools/isl/Makefile b/tools/isl/Makefile
new file mode 100644
index 0000000000..8fe2da1a06
--- /dev/null
+++ b/tools/isl/Makefile
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2009-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=isl
+PKG_VERSION:=0.14.1
+
+PKG_SOURCE_URL:=http://isl.gforge.inria.fr
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_MD5SUM:=94fcd11e0b1c79250ae341affb1845ea
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+unexport CFLAGS
+
+HOST_CONFIGURE_ARGS += \
+ --enable-static \
+ --disable-shared \
+ --with-gmp-prefix=$(STAGING_DIR_HOST)
+
+$(eval $(call HostBuild))